mpc85xx: use image metadata
[openwrt/openwrt.git] / target / linux / mpc85xx / Makefile
index 5f3ad6c3d4968774229e51cdaab06805347189e5..b181e67c0e5e126697485eb59681947a0a0b5433 100644 (file)
@@ -12,24 +12,16 @@ BOARDNAME:=Freescale MPC85xx
 CPU_TYPE:=8540
 FEATURES:=squashfs
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
-SUBTARGETS=generic p1020
+SUBTARGETS:=generic p1020
 
-KERNEL_PATCHVER:=3.18
+KERNEL_PATCHVER:=4.9
 
-include $(INCLUDE_DIR)/target.mk
+KERNELNAME:=zImage
 
-KERNEL_IMAGES := zImage
-ifeq ($(SUBTARGET),generic)
-KERNEL_IMAGES += cuImage.tl-wdr4900-v1
-endif
+include $(INCLUDE_DIR)/target.mk
 
 DEFAULT_PACKAGES += \
        kmod-input-core kmod-input-gpio-keys kmod-button-hotplug \
-       kmod-leds-gpio kmod-booke-wdt \
-       swconfig kmod-ath9k wpad-mini
-
-define Target/Description
-       Build images for the Freescale MPC85xx based boards.
-endef
+       kmod-leds-gpio swconfig kmod-ath9k wpad-mini
 
 $(eval $(call BuildTarget))