mpc85xx: use image metadata
[openwrt/openwrt.git] / target / linux / mpc85xx / Makefile
index 7f986452c557c26873dfe4e9a3249c87875517ca..b181e67c0e5e126697485eb59681947a0a0b5433 100644 (file)
@@ -12,21 +12,14 @@ BOARDNAME:=Freescale MPC85xx
 CPU_TYPE:=8540
 FEATURES:=squashfs
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
-SUBTARGETS=generic p1020
+SUBTARGETS:=generic p1020
 
-KERNEL_PATCHVER:=4.4
+KERNEL_PATCHVER:=4.9
 
-define Target/Description
-       Build images for the Freescale MPC85xx based boards.
-endef
+KERNELNAME:=zImage
 
 include $(INCLUDE_DIR)/target.mk
 
-KERNEL_IMAGES := zImage
-ifeq ($(SUBTARGET),generic)
-KERNEL_IMAGES += cuImage.tl-wdr4900-v1
-endif
-
 DEFAULT_PACKAGES += \
        kmod-input-core kmod-input-gpio-keys kmod-button-hotplug \
        kmod-leds-gpio swconfig kmod-ath9k wpad-mini