mpc85xx: use image metadata
[openwrt/openwrt.git] / target / linux / mpc85xx / Makefile
index cadf66519691d0bd126a3fc545d0c95311aa6771..b181e67c0e5e126697485eb59681947a0a0b5433 100644 (file)
@@ -9,22 +9,19 @@ include $(TOPDIR)/rules.mk
 ARCH:=powerpc
 BOARD:=mpc85xx
 BOARDNAME:=Freescale MPC85xx
-CFLAGS:=-Os -pipe -fno-caller-saves -mcpu=8540
-FEATURES:=spe_fpu squashfs
+CPU_TYPE:=8540
+FEATURES:=squashfs
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
-SUBTARGETS=generic p1020
+SUBTARGETS:=generic p1020
 
-LINUX_VERSION:=3.8.12
+KERNEL_PATCHVER:=4.9
+
+KERNELNAME:=zImage
 
 include $(INCLUDE_DIR)/target.mk
 
 DEFAULT_PACKAGES += \
        kmod-input-core kmod-input-gpio-keys kmod-button-hotplug \
-       kmod-leds-gpio kmod-booke-wdt \
-       swconfig kmod-ath9k wpad-mini
-
-define Target/Description
-       Build images for the Freescale MPC85xx based boards.
-endef
+       kmod-leds-gpio swconfig kmod-ath9k wpad-mini
 
 $(eval $(call BuildTarget))