mvebu: Add subtarget for Cortex A9 build
[openwrt/openwrt.git] / target / linux / mvebu / Makefile
index 52e667b7e978bb5c08d96a90ee326339f36661bf..93491954abd520972e123c557326a8c75006f3d6 100644 (file)
@@ -1,24 +1,21 @@
 #
-# Copyright (C) 2012 OpenWrt.org
+# Copyright (C) 2012-2015 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
 include $(TOPDIR)/rules.mk
 
-ARCH:=arm
 BOARD:=mvebu
-BOARDNAME:=Marvell Armada XP/370 boards
-FEATURES:=targz usb jffs2 pci pcie gpio
-CFLAGS:=-Os -pipe -march=armv7-a -mfpu=vfpv3-d16 -mfloat-abi=softfp
-MAINTAINER:=Florian Fainelli <florian@openwrt.org>
+BOARDNAME:=Marvell Armada 37x/38x/XP
+FEATURES:=fpu usb pci pcie gpio nand squashfs ramdisk
+SUBTARGETS:=cortexa9
+MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
-LINUX_VERSION:=3.8-rc6
+KERNEL_PATCHVER:=4.14
 
 include $(INCLUDE_DIR)/target.mk
 
-KERNELNAME:="zImage dtbs"
-
-DEFAULT_PACKAGES +=
+DEFAULT_PACKAGES += uboot-envtools kmod-gpio-button-hotplug
 
 $(eval $(call BuildTarget))