mwlwifi: add and use individual firmware packages
[openwrt/openwrt.git] / target / linux / mvebu / image / Makefile
index 8b203a41229e6446de063655d99107dc6d3c454e..53ce02882dbac1e8c5abbf719f3199b87eeb30f1 100644 (file)
@@ -17,32 +17,26 @@ define Build/dtb
         $(call Image/BuildDTB,$(DTS_DIR)/$(DEVICE_DTS).dts,$@.dtb)
 endef
 
-define Build/clearfog-bundle
-       rm -f $@.new
-       $(TAR) -cp --numeric-owner --owner=0 --group=0 --sort=name \
-               $(if $(SOURCE_DATE_EPOCH),--mtime="@$(SOURCE_DATE_EPOCH)") \
-               --file=$@.new -C $(TARGET_DIR)/ .
-       $(TAR) -rp --numeric-owner --owner=0 --group=0 --sort=name \
-               $(if $(SOURCE_DATE_EPOCH),--mtime="@$(SOURCE_DATE_EPOCH)") \
-               --file=$@.new -C $(dir $(IMAGE_KERNEL)) $(notdir $(IMAGE_KERNEL)) $(notdir $(IMAGE_KERNEL).dtb)
-       gzip -9n -c $@.new > $@
-endef
-
 # SD-Card Images:
 # these values are optimized for a 4GB labeled sdcard that actually holds 7744512 sectors of 512 byte
 # MBR:            2048 sectors
 # Partition 1:   32768 sectors
 # Partition 2:   98304 sectors (configurable)
 
-define Build/boot-scr
+define Build/boot-scr-cfpro
+       rm -f $@.bootscript
+       mkimage -A arm -O linux -T script -C none -a 0 -e 0 -d cfpro-boot.script $@.bootscript
+endef
+
+define Build/boot-scr-cfbase
        rm -f $@.bootscript
-       mkimage -A arm -O linux -T script -C none -a 0 -e 0 -d boot.script $@.bootscript
+       mkimage -A arm -O linux -T script -C none -a 0 -e 0 -d cfbase-boot.script $@.bootscript
 endef
 
 define Build/boot-img
        rm -f $@.boot
        mkfs.fat -C $@.boot 16384
-       $(foreach dts,$(DEVICE_DTS), mcopy -i $@.boot $(DTS_DIR)/$(dts).dtb ::$(dts).dtb)
+       $(foreach dts,$(DEVICE_DTS), mcopy -i $@.boot $(DTS_DIR)/$(dts).dtb ::$(dts).dtb;)
        mcopy -i $@.boot $(IMAGE_KERNEL) ::zImage
        mcopy -i $@.boot $@.bootscript ::boot.scr
 endef
@@ -50,7 +44,7 @@ endef
 define Build/sdcard-img
        ROOTFS_SIZE=$$(( $(CONFIG_TARGET_ROOTFS_PARTSIZE) * 1024 * 2 )); \
        ./gen_mvebu_sdcard_img.sh $@ \
-               "$(KDIR)/openwrt-mvebu-clearfog-u-boot-spl.kwb" \
+               "$(STAGING_DIR_IMAGE)/clearfog-u-boot-spl.kwb" \
                c 32768 $@.boot \
                83 $$ROOTFS_SIZE $(IMAGE_ROOTFS)
 endef
@@ -111,6 +105,7 @@ define Device/linksys-wrt1200ac
   $(call Device/linksys,WRT1200AC (Caiman))
   $(Device/armada-385-linksys)
   DEVICE_DTS := armada-385-linksys-caiman
+  DEVICE_PACKAGES += mwlwifi-firmware-88w8864
 endef
 TARGET_DEVICES += linksys-wrt1200ac
 
@@ -118,6 +113,7 @@ define Device/linksys-wrt1900acv2
   $(call Device/linksys,WRT1900ACv2 (Cobra))
   $(Device/armada-385-linksys)
   DEVICE_DTS := armada-385-linksys-cobra
+  DEVICE_PACKAGES += mwlwifi-firmware-88w8864
 endef
 TARGET_DEVICES += linksys-wrt1900acv2
 
@@ -125,6 +121,7 @@ define Device/linksys-wrt3200acm
   $(call Device/linksys,WRT3200ACM (Rango))
   $(Device/armada-385-linksys)
   DEVICE_DTS := armada-385-linksys-rango
+  DEVICE_PACKAGES += kmod-btmrvl kmod-mwifiex-sdio mwlwifi-firmware-88w8964
 endef
 TARGET_DEVICES += linksys-wrt3200acm
 
@@ -132,28 +129,30 @@ define Device/linksys-wrt1900acs
   $(call Device/linksys,WRT1900ACS (Shelby))
   $(Device/armada-385-linksys)
   DEVICE_DTS := armada-385-linksys-shelby
+  DEVICE_PACKAGES += mwlwifi-firmware-88w8864
 endef
 TARGET_DEVICES += linksys-wrt1900acs
 
 define Device/linksys-wrt1900ac
   $(call Device/linksys,WRT1900AC (Mamba))
   DEVICE_DTS := armada-xp-linksys-mamba
+  DEVICE_PACKAGES += mwlwifi-firmware-88w8864
   $(Device/NAND-128K)
   $(Device/UBI-factory)
   KERNEL_SIZE := 3072k
 endef
 TARGET_DEVICES += linksys-wrt1900ac
 
-define Device/openblocks-ax3
+define Device/openblocks-ax3-4
   $(Device/UBI-factory)
   DEVICE_DTS := armada-xp-openblocks-ax3-4
-  SUPPORTED_DEVCES := $(1)
+  SUPPORTED_DEVICES := $(1)
   BLOCKSIZE := 128k
   PAGESIZE := 1
   IMAGE/factory.img := append-kernel | pad-to $$(BLOCKSIZE) | append-ubi
   DEVICE_TITLE := Plat'Home OpenBlocks AX3
 endef
-TARGET_DEVICES += openblocks-ax3
+TARGET_DEVICES += openblocks-ax3-4
 
 define Device/armada-385-db-ap
   $(Device/NAND-256K)
@@ -168,11 +167,25 @@ define Device/marvell-nand
   DEVICE_TITLE := Marvell Armada $(1)
 endef
 
-Device/armada-370-db = $(call Device/marvell-nand,370 DB (DB-88F6710-BP-DDR3))
-Device/armada-370-rd = $(call Device/marvell-nand,370 RD (RD-88F6710-A1))
-Device/armada-xp-db = $(call Device/marvell-nand,XP DB (DB-78460-BP))
-Device/armada-xp-gp = $(call Device/marvell-nand,XP GP (DB-MV784MP-GP))
-TARGET_DEVICES += armada-370-db armada-370-rd armada-xp-db armada-xp-gp
+define Device/armada-370-db
+       $(call Device/marvell-nand,370 DB (DB-88F6710-BP-DDR3))
+endef
+TARGET_DEVICES += armada-370-db
+
+define Device/armada-370-rd
+       $(call Device/marvell-nand,370 RD (RD-88F6710-A1))
+endef
+TARGET_DEVICES += armada-370-rd
+
+define Device/armada-xp-db
+       $(call Device/marvell-nand,XP DB (DB-78460-BP))
+endef
+TARGET_DEVICES += armada-xp-db
+
+define Device/armada-xp-gp
+       $(call Device/marvell-nand,XP GP (DB-MV784MP-GP))
+endef
+TARGET_DEVICES += armada-xp-gp
 
 define Device/armada-388-rd
   DEVICE_TITLE := Marvell Armada 388 RD (RD-88F6820-AP)
@@ -181,22 +194,35 @@ define Device/armada-388-rd
 endef
 TARGET_DEVICES += armada-388-rd
 
-define Device/armada-388-clearfog
+define Device/armada-388-clearfog-pro
   KERNEL_INSTALL := 1
-  KERNEL := dtb | kernel-bin
-  DEVICE_TITLE := SolidRun ClearFog
+  KERNEL := kernel-bin
+  DEVICE_TITLE := SolidRun ClearFog Pro
   DEVICE_PACKAGES := mkf2fs e2fsprogs swconfig kmod-fs-vfat kmod-nls-cp437 kmod-nls-iso8859-1
-  IMAGES := bundle.tar.gz sdcard.img.gz
-  IMAGE/bundle.tar.gz := clearfog-bundle
-  IMAGE/sdcard.img.gz := boot-scr | boot-img | sdcard-img | gzip
+  IMAGES := sdcard.img.gz
+  IMAGE/sdcard.img.gz := boot-scr-cfpro | boot-img | sdcard-img | gzip | append-metadata
+  IMAGE_NAME = $$(IMAGE_PREFIX)-$$(2)
+  DEVICE_DTS := armada-388-clearfog-pro armada-388-clearfog-base
+  SUPPORTED_DEVICES := armada-388-clearfog-pro armada-388-clearfog
+endef
+TARGET_DEVICES += armada-388-clearfog-pro
+
+define Device/armada-388-clearfog-base
+  KERNEL_INSTALL := 1
+  KERNEL := kernel-bin
+  DEVICE_TITLE := SolidRun ClearFog Base
+  DEVICE_PACKAGES := mkf2fs e2fsprogs kmod-fs-vfat kmod-nls-cp437 kmod-nls-iso8859-1
+  IMAGES := sdcard.img.gz
+  IMAGE/sdcard.img.gz := boot-scr-cfbase | boot-img | sdcard-img | gzip | append-metadata
   IMAGE_NAME = $$(IMAGE_PREFIX)-$$(2)
+  DEVICE_DTS := armada-388-clearfog-pro armada-388-clearfog-base
 endef
-TARGET_DEVICES += armada-388-clearfog
+TARGET_DEVICES += armada-388-clearfog-base
 
 define Device/globalscale-mirabox
   $(Device/NAND-512K)
   DEVICE_DTS := armada-370-mirabox
-  SUPPORTED_DEVCES := mirabox
+  SUPPORTED_DEVICES := mirabox
   DEVICE_TITLE := Globalscale Mirabox
 endef
 TARGET_DEVICES += globalscale-mirabox