uboot-mvebu: make hidden and be m for clearfog to fix IB failing to add it
[openwrt/openwrt.git] / target / linux / mvebu / image / Makefile
index f3eda17a0bfc1d9fdd5a450efccded041e46b5b2..7d58ed7df4e4ecfc7f68aa3a9bb809148dab8f43 100644 (file)
@@ -12,8 +12,6 @@ include $(INCLUDE_DIR)/image.mk
 
 KERNEL_LOADADDR := 0x00008000
 
-DEVICE_VARS += KERNEL_SIZE
-
 define Build/dtb
         $(call Image/BuildDTB,$(DTS_DIR)/$(DEVICE_DTS).dts,$@.dtb)
 endef
@@ -51,7 +49,7 @@ endef
 define Build/sdcard-img
        ROOTFS_SIZE=$$(( $(CONFIG_TARGET_ROOTFS_PARTSIZE) * 1024 * 2 )); \
        ./gen_mvebu_sdcard_img.sh $@ \
-               "$(BIN_DIR)/uboot-mvebu-clearfog/openwrt-mvebu-clearfog-u-boot-spl.kwb" \
+               "$(KDIR)/openwrt-mvebu-clearfog-u-boot-spl.kwb" \
                c 32768 $@.boot \
                83 $$ROOTFS_SIZE $(IMAGE_ROOTFS)
 endef
@@ -71,8 +69,9 @@ endef
 
 define Device/UBI-factory
   $(Device/UBI)
+  UBINIZE_OPTS := -E 5
   IMAGES += factory.img
-  IMAGE/factory.img := append-kernel $$$$(KERNEL_SIZE) | append-ubi | pad-to $$$$(PAGESIZE)
+  IMAGE/factory.img := append-kernel | pad-to $$$$(KERNEL_SIZE) | append-ubi | pad-to $$$$(PAGESIZE)
 endef
 
 define Device/NAND-128K
@@ -141,7 +140,7 @@ define Device/openblocks-ax3
   DEVICE_DTS := armada-xp-openblocks-ax3-4
   BLOCKSIZE := 128k
   PAGESIZE := 1
-  IMAGE/factory.img := append-kernel $$$$(KERNEL_SIZE) | append-ubi
+  IMAGE/factory.img := append-kernel | pad-to $$(BLOCKSIZE) | append-ubi
   DEVICE_TITLE := Plat'Home OpenBlocks AX3
 endef
 TARGET_DEVICES += openblocks-ax3
@@ -168,7 +167,7 @@ TARGET_DEVICES += armada-370-db armada-370-rd armada-xp-db armada-xp-gp
 define Device/armada-388-rd
   DEVICE_TITLE := Marvell Armada 388 RD (RD-88F6820-AP)
   IMAGES := firmware.bin
-  IMAGE/firmware.bin := append-kernel 256k | append-rootfs | pad-rootfs
+  IMAGE/firmware.bin := append-kernel | pad-to 256k | append-rootfs | pad-rootfs
 endef
 TARGET_DEVICES += armada-388-rd
 
@@ -176,7 +175,7 @@ define Device/armada-388-clearfog
   KERNEL_INSTALL := 1
   KERNEL := dtb | kernel-bin
   DEVICE_TITLE := SolidRun ClearFog
-  DEVICE_PACKAGES := uboot-mvebu-clearfog mkf2fs e2fsprogs
+  DEVICE_PACKAGES := mkf2fs e2fsprogs
   IMAGES := bundle.tar.gz sdcard.img.gz
   IMAGE/bundle.tar.gz := clearfog-bundle
   IMAGE/sdcard.img.gz := boot-scr | boot-img | sdcard-img | gzip