mvebu: clearfog: include DTB for all variants in image
[openwrt/openwrt.git] / target / linux / mvebu / image / Makefile
index d8517a9bdbc99194c432c0c2df15ed29ea46b072..b5014161c62412e7a68b4c877ed3f03f4957dff5 100644 (file)
@@ -17,32 +17,26 @@ define Build/dtb
         $(call Image/BuildDTB,$(DTS_DIR)/$(DEVICE_DTS).dts,$@.dtb)
 endef
 
-define Build/clearfog-bundle
-       rm -f $@.new
-       $(TAR) -cp --numeric-owner --owner=0 --group=0 --sort=name \
-               $(if $(SOURCE_DATE_EPOCH),--mtime="@$(SOURCE_DATE_EPOCH)") \
-               --file=$@.new -C $(TARGET_DIR)/ .
-       $(TAR) -rp --numeric-owner --owner=0 --group=0 --sort=name \
-               $(if $(SOURCE_DATE_EPOCH),--mtime="@$(SOURCE_DATE_EPOCH)") \
-               --file=$@.new -C $(dir $(IMAGE_KERNEL)) $(notdir $(IMAGE_KERNEL)) $(notdir $(IMAGE_KERNEL).dtb)
-       gzip -9n -c $@.new > $@
-endef
-
 # SD-Card Images:
 # these values are optimized for a 4GB labeled sdcard that actually holds 7744512 sectors of 512 byte
 # MBR:            2048 sectors
 # Partition 1:   32768 sectors
 # Partition 2:   98304 sectors (configurable)
 
-define Build/boot-scr
+define Build/boot-scr-cfpro
+       rm -f $@.bootscript
+       mkimage -A arm -O linux -T script -C none -a 0 -e 0 -d cfpro-boot.script $@.bootscript
+endef
+
+define Build/boot-scr-cfbase
        rm -f $@.bootscript
-       mkimage -A arm -O linux -T script -C none -a 0 -e 0 -d boot.script $@.bootscript
+       mkimage -A arm -O linux -T script -C none -a 0 -e 0 -d cfbase-boot.script $@.bootscript
 endef
 
 define Build/boot-img
        rm -f $@.boot
        mkfs.fat -C $@.boot 16384
-       $(foreach dts,$(DEVICE_DTS), mcopy -i $@.boot $(DTS_DIR)/$(dts).dtb ::$(dts).dtb)
+       $(foreach dts,$(DEVICE_DTS), mcopy -i $@.boot $(DTS_DIR)/$(dts).dtb ::$(dts).dtb;)
        mcopy -i $@.boot $(IMAGE_KERNEL) ::zImage
        mcopy -i $@.boot $@.bootscript ::boot.scr
 endef
@@ -50,7 +44,7 @@ endef
 define Build/sdcard-img
        ROOTFS_SIZE=$$(( $(CONFIG_TARGET_ROOTFS_PARTSIZE) * 1024 * 2 )); \
        ./gen_mvebu_sdcard_img.sh $@ \
-               "$(KDIR)/openwrt-mvebu-clearfog-u-boot-spl.kwb" \
+               "$(STAGING_DIR_IMAGE)/clearfog-u-boot-spl.kwb" \
                c 32768 $@.boot \
                83 $$ROOTFS_SIZE $(IMAGE_ROOTFS)
 endef
@@ -125,6 +119,7 @@ define Device/linksys-wrt3200acm
   $(call Device/linksys,WRT3200ACM (Rango))
   $(Device/armada-385-linksys)
   DEVICE_DTS := armada-385-linksys-rango
+  DEVICE_PACKAGES += kmod-mwifiex-sdio
 endef
 TARGET_DEVICES += linksys-wrt3200acm
 
@@ -181,17 +176,33 @@ define Device/armada-388-rd
 endef
 TARGET_DEVICES += armada-388-rd
 
-define Device/armada-388-clearfog
+define Device/armada-388-clearfog-pro
   KERNEL_INSTALL := 1
-  KERNEL := dtb | kernel-bin
-  DEVICE_TITLE := SolidRun ClearFog
+  KERNEL := kernel-bin
+  DEVICE_TITLE := SolidRun ClearFog Pro
   DEVICE_PACKAGES := mkf2fs e2fsprogs swconfig kmod-fs-vfat kmod-nls-cp437 kmod-nls-iso8859-1
-  IMAGES := bundle.tar.gz sdcard.img.gz
-  IMAGE/bundle.tar.gz := clearfog-bundle
-  IMAGE/sdcard.img.gz := boot-scr | boot-img | sdcard-img | gzip
+  IMAGES := sdcard.img.gz
+  IMAGE/sdcard.img.gz := boot-scr-cfpro | boot-img | sdcard-img | gzip | append-metadata
+  IMAGE_NAME = $$(IMAGE_PREFIX)-$$(2)
+  DEVICE_DTS := armada-388-clearfog-pro armada-388-clearfog-base
+endef
+TARGET_DEVICES += armada-388-clearfog-pro
+
+define Device/armada-388-clearfog-base
+  KERNEL_INSTALL := 1
+  KERNEL := kernel-bin
+  DEVICE_TITLE := SolidRun ClearFog Base
+  DEVICE_PACKAGES := \
+         kmod-nls-cp437 kmod-nls-iso8859-1 \
+         mkf2fs e2fsprogs kmod-fs-vfat kmod-fuse kmod-fs-f2fs \
+         kmod-ata-core kmod-ata-ahci kmod-ata-marvell-sata kmod-scsi-core kmod-scsi-generic \
+         kmod-button-hotplug kmod-gpio-button-hotplug
+  IMAGES := sdcard.img.gz
+  IMAGE/sdcard.img.gz := boot-scr-cfbase | boot-img | sdcard-img | gzip
   IMAGE_NAME = $$(IMAGE_PREFIX)-$$(2)
+  DEVICE_DTS := armada-388-clearfog-pro armada-388-clearfog-base
 endef
-TARGET_DEVICES += armada-388-clearfog
+TARGET_DEVICES += armada-388-clearfog-base
 
 define Device/globalscale-mirabox
   $(Device/NAND-512K)