build: drop UBI EOF marker from images by default
[openwrt/openwrt.git] / target / linux / mvebu / image / Makefile
index f3eda17a0bfc1d9fdd5a450efccded041e46b5b2..c855cca42cc4f917ff35f762e64c2804c0153091 100644 (file)
@@ -71,6 +71,7 @@ endef
 
 define Device/UBI-factory
   $(Device/UBI)
+  UBINIZE_OPTS := -E 5
   IMAGES += factory.img
   IMAGE/factory.img := append-kernel $$$$(KERNEL_SIZE) | append-ubi | pad-to $$$$(PAGESIZE)
 endef
@@ -141,7 +142,7 @@ define Device/openblocks-ax3
   DEVICE_DTS := armada-xp-openblocks-ax3-4
   BLOCKSIZE := 128k
   PAGESIZE := 1
-  IMAGE/factory.img := append-kernel $$$$(KERNEL_SIZE) | append-ubi
+  IMAGE/factory.img := append-kernel | pad-to $$(BLOCKSIZE) | append-ubi
   DEVICE_TITLE := Plat'Home OpenBlocks AX3
 endef
 TARGET_DEVICES += openblocks-ax3