octeon: drop unsupported jffs2 feature flag
[openwrt/openwrt.git] / target / linux / octeon / Makefile
index 0085d22689ea2f91524e9fd6486d445ee76298cd..4a6d974b98aec31989c4e1df397bafd6efdc7edc 100644 (file)
@@ -6,14 +6,15 @@
 #
 include $(TOPDIR)/rules.mk
 
-ARCH:=mips
+ARCH:=mips64
 BOARD:=octeon
 BOARDNAME:=Cavium Networks Octeon
-FEATURES:=squashfs jffs2 pci usb
-CFLAGS:=-Os -pipe -march=octeon -fno-caller-saves
-MAINTAINER:=John Crispin <blogic@openwrt.org>
+FEATURES:=squashfs ext4 initramfs pci usb
+CPU_TYPE:=octeon
+CPU_CFLAGS_octeon:=-march=octeon -mabi=64
+MAINTAINER:=John Crispin <john@phrozen.org>
 
-LINUX_VERSION:=3.10.10
+KERNEL_PATCHVER:=4.4
 
 include $(INCLUDE_DIR)/target.mk