octeon: drop unsupported jffs2 feature flag
[openwrt/openwrt.git] / target / linux / octeon / Makefile
index 68d1eafd878fe8b9bd06d7f4703960aa22fc16b2..4a6d974b98aec31989c4e1df397bafd6efdc7edc 100644 (file)
@@ -1,23 +1,23 @@
 #
-# Copyright (C) 2009-2011 OpenWrt.org
+# Copyright (C) 2013 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
 include $(TOPDIR)/rules.mk
 
-ARCH:=mips
+ARCH:=mips64
 BOARD:=octeon
 BOARDNAME:=Cavium Networks Octeon
-FEATURES:=squashfs jffs2 pci usb broken
-CFLAGS:=-Os -pipe -march=octeon -fno-caller-saves
-MAINTAINER:=Florian Fainelli <florian@openwrt.org>
+FEATURES:=squashfs ext4 initramfs pci usb
+CPU_TYPE:=octeon
+CPU_CFLAGS_octeon:=-march=octeon -mabi=64
+MAINTAINER:=John Crispin <john@phrozen.org>
 
-LINUX_VERSION:=2.6.37.6
+KERNEL_PATCHVER:=4.4
 
 include $(INCLUDE_DIR)/target.mk
 
-DEFAULT_PACKAGES += wpad-mini
 
 define Target/Description
        Build firmware images for Cavium Networks Octeon-based boards.