octeon: drop unsupported jffs2 feature flag
[openwrt/openwrt.git] / target / linux / octeon / Makefile
index 7fd54a9c8b8707a9904fd6298fa718e04a076de9..4a6d974b98aec31989c4e1df397bafd6efdc7edc 100644 (file)
@@ -6,15 +6,15 @@
 #
 include $(TOPDIR)/rules.mk
 
-ARCH:=mips
+ARCH:=mips64
 BOARD:=octeon
 BOARDNAME:=Cavium Networks Octeon
-FEATURES:=squashfs jffs2 pci usb
+FEATURES:=squashfs ext4 initramfs pci usb
 CPU_TYPE:=octeon
-CPU_CFLAGS_octeon:=-march=octeon
-MAINTAINER:=John Crispin <blogic@openwrt.org>
+CPU_CFLAGS_octeon:=-march=octeon -mabi=64
+MAINTAINER:=John Crispin <john@phrozen.org>
 
-LINUX_VERSION:=3.10.21
+KERNEL_PATCHVER:=4.4
 
 include $(INCLUDE_DIR)/target.mk