octeon: drop unsupported jffs2 feature flag
[openwrt/openwrt.git] / target / linux / octeon / Makefile
index 816f5991284ec13660e493272d60200365d0ee9b..4a6d974b98aec31989c4e1df397bafd6efdc7edc 100644 (file)
@@ -1,22 +1,23 @@
 #
-# Copyright (C) 2009 OpenWrt.org
+# Copyright (C) 2013 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
 include $(TOPDIR)/rules.mk
 
-ARCH:=mips
+ARCH:=mips64
 BOARD:=octeon
 BOARDNAME:=Cavium Networks Octeon
-FEATURES:=squashfs jffs2 pci
-CFLAGS:=-Os -pipe -funit-at-a-time
+FEATURES:=squashfs ext4 initramfs pci usb
+CPU_TYPE:=octeon
+CPU_CFLAGS_octeon:=-march=octeon -mabi=64
+MAINTAINER:=John Crispin <john@phrozen.org>
 
-LINUX_VERSION:=2.6.30.2
+KERNEL_PATCHVER:=4.4
 
 include $(INCLUDE_DIR)/target.mk
 
-DEFAULT_PACKAGES += hostapd-mini
 
 define Target/Description
        Build firmware images for Cavium Networks Octeon-based boards.