octeon: re-enable CONFIG_CAVIUM_CN63XXP1 and EdgeRouter image
[openwrt/openwrt.git] / target / linux / octeon / image / Makefile
index ec301ee9423551ddd04188db41570b03bedd7248..11da22df3bd49f467e2fba5e7da59d807cefe766 100644 (file)
@@ -1,46 +1,74 @@
+# SPDX-License-Identifier: GPL-2.0-only
 #
 # Copyright (C) 2009-2010 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
+
 include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/image.mk
 
+define Build/append-dtb-to-elf
+       $(TARGET_CROSS)objcopy --update-section .appended_dtb=$(KDIR)/image-$(DEVICE_DTS).dtb $@
+endef
+
+define Build/strip-kernel
+       # Workaround pre-SDK-1.9.0 u-boot versions not handling the .notes section
+       $(TARGET_CROSS)strip -R .notes $@ -o $@.stripped && mv $@.stripped $@
+endef
+
+DTS_DIR := $(DTS_DIR)/cavium-octeon
+
 define Device/Default
   PROFILES = Default $$(DEVICE_NAME)
   KERNEL_NAME := vmlinux.elf
   KERNEL_INITRAMFS_NAME := vmlinux-initramfs.elf
   KERNEL := kernel-bin | strip-kernel | patch-cmdline
   IMAGES := sysupgrade.tar
-  IMAGE/sysupgrade.tar/squashfs := append-rootfs | pad-rootfs | sysupgrade-tar rootfs=$$$$@
+  IMAGE/sysupgrade.tar/squashfs := append-rootfs | pad-extra 128k | sysupgrade-tar rootfs=$$$$@
   IMAGE/sysupgrade.tar := sysupgrade-tar
-  FILESYSTEMS := squashfs
-endef
-
-define Build/strip-kernel
-       # Workaround pre-SDK-1.9.0 u-boot versions not handling the .notes section
-       $(TARGET_CROSS)strip -R .notes $@ -o $@.stripped && mv $@.stripped $@
 endef
 
 define Device/generic
+  DEVICE_VENDOR := Generic
+  DEVICE_MODEL := Octeon
   FILESYSTEMS := ext4
-  DEVICE_TITLE := Generic
 endef
 TARGET_DEVICES += generic
 
-ER_CMDLINE:=-mtdparts=phys_mapped_flash:640k(boot0)ro,640k(boot1)ro,64k(eeprom)ro block2mtd.block2mtd=/dev/mmcblk0p2,65536,rootfs,5 root=/dev/mtdblock3 rootfstype=squashfs rootwait
-define Device/er
-  CMDLINE := $(ER_CMDLINE) 
-  DEVICE_TITLE := Ubiquiti EdgeRouter
+ITUSROUTER_CMDLINE:=console=ttyS0,115200 root=/dev/mmcblk1p2 rootfstype=squashfs,ext4,f2fs rootwait
+define Device/itus_shield-router
+  DEVICE_VENDOR := Itus Networks
+  DEVICE_MODEL := Shield Router
+  CMDLINE := $(ITUSROUTER_CMDLINE)
+  IMAGE/sysupgrade.tar/squashfs += | append-metadata
+endef
+TARGET_DEVICES += itus_shield-router
+
+ER_CMDLINE:=-mtdparts=phys_mapped_flash:640k(boot0)ro,640k(boot1)ro,64k(eeprom)ro root=/dev/mmcblk0p2 rootfstype=squashfs,ext4 rootwait
+define Device/ubnt_edgerouter
+  DEVICE_VENDOR := Ubiquiti
+  DEVICE_MODEL := EdgeRouter
+  BOARD_NAME := er
+  CMDLINE := $(ER_CMDLINE)
+endef
+TARGET_DEVICES += ubnt_edgerouter
+
+define Device/ubnt_edgerouter-4
+  DEVICE_VENDOR := Ubiquiti
+  DEVICE_MODEL := EdgeRouter 4
+  DEVICE_DTS := cn7130_ubnt_edgerouter-4
+  DEVICE_PACKAGES += kmod-gpio-button-hotplug kmod-leds-gpio kmod-of-mdio kmod-sfp kmod-usb3 kmod-usb-dwc3 kmod-usb-storage-uas
+  KERNEL := kernel-bin | patch-cmdline | append-dtb-to-elf
+  KERNEL_DEPENDS := $$(wildcard $(DTS_DIR)/$(DEVICE_DTS).dts)
+  CMDLINE := root=/dev/mmcblk0p2 rootfstype=squashfs,ext4 rootwait
 endef
-TARGET_DEVICES += er
+TARGET_DEVICES += ubnt_edgerouter-4
 
-ERLITE_CMDLINE:=-mtdparts=phys_mapped_flash:512k(boot0),512k(boot1),64k@1024k(eeprom) block2mtd.block2mtd=/dev/sda2,65536,rootfs,5 root=/dev/mtdblock3 rootfstype=squashfs rootwait
-define Device/erlite
-  CMDLINE := $(ERLITE_CMDLINE) 
-  DEVICE_TITLE := Ubiquiti EdgeRouter Lite
+ERLITE_CMDLINE:=-mtdparts=phys_mapped_flash:512k(boot0)ro,512k(boot1)ro,64k(eeprom)ro root=/dev/sda2 rootfstype=squashfs,ext4 rootwait
+define Device/ubnt_edgerouter-lite
+  DEVICE_VENDOR := Ubiquiti
+  DEVICE_MODEL := EdgeRouter Lite
+  BOARD_NAME := erlite
+  CMDLINE := $(ERLITE_CMDLINE)
 endef
-TARGET_DEVICES += erlite
+TARGET_DEVICES += ubnt_edgerouter-lite
 
 $(eval $(call BuildImage))