drop the bootscript, new u-boots won't need it
[openwrt/openwrt.git] / target / linux / omap / Makefile
index 3a62911ca393f5957805a6f36f2a5f4f0b9e9553..3496018306e83ca44cfd1e8b3c7400992a4c12b2 100644 (file)
@@ -9,15 +9,17 @@ include $(TOPDIR)/rules.mk
 ARCH:=arm
 BOARD:=omap
 BOARDNAME:=TI OMAP3/4/AM33xx
-FEATURES:=usb targz audio display
+FEATURES:=usb usbgadget ext4 targz fpu audio display
 CPU_TYPE:=cortex-a9
 CPU_SUBTYPE:=vfpv3
 
-LINUX_VERSION:=3.3.8
+LINUX_VERSION:=3.12
 
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
-KERNELNAME:="uImage"
+KERNELNAME:="zImage dtbs"
+
+include $(INCLUDE_DIR)/target.mk
 
 DEFAULT_PACKAGES += uboot-omap-am335x_evm uboot-omap-omap3_beagle uboot-omap-omap3_overo uboot-omap-omap4_panda
 
@@ -27,6 +29,4 @@ define Target/Description
        TI OMAP boards
 endef
 
-include $(INCLUDE_DIR)/target.mk
-
 $(eval $(call BuildTarget))