orion: fix KERNELNAME
[openwrt/openwrt.git] / target / linux / orion / Makefile
index 2dc5d2530c56e9a42da43c9fdf3c6e2482c3d6f5..41fd875cda4d704bc3b35e4bccedf8b6b229587b 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2008-2011 OpenWrt.org
+# Copyright (C) 2008-2013 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -10,15 +10,14 @@ ARCH:=arm
 BOARD:=orion
 BOARDNAME:=Marvell Orion
 SUBTARGETS:=generic harddisk
-CFLAGS=-Os -pipe -march=armv5t -mtune=xscale -funit-at-a-time
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
-LINUX_VERSION:=2.6.37
+LINUX_VERSION:=3.3.8
 
 include $(INCLUDE_DIR)/target.mk
 
-KERNELNAME:="uImage"
+KERNELNAME:="zImage"
 
-DEFAULT_PACKAGES += kmod-ath9k kmod-crypto-mv-cesa wpad-mini
+DEFAULT_PACKAGES += kmod-ath9k kmod-crypto-mv-cesa wpad-mini kmod-i2c-core kmod-i2c-mv64xxx kmod-rtc-isl1208
 
 $(eval $(call BuildTarget))