ppc40x: don't force usb feature
[openwrt/openwrt.git] / target / linux / ppc40x / Makefile
index 38c16c1e346b282f1bb6153d5d0c31b97a417be6..c3181ab61780989afc77c17ec0402e50a26dd729 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2008 OpenWrt.org
+# Copyright (C) 2008-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -10,14 +10,15 @@ ARCH:=powerpc
 BOARD:=ppc40x
 BOARDNAME:=AMCC/IBM PPC40x
 FEATURES:=squashfs
+CFLAGS:=-Os -pipe -funit-at-a-time -mcpu=405
 
-LINUX_VERSION:=2.6.26.3
+LINUX_VERSION:=2.6.30.8
 LINUX_KARCH:=powerpc
 
 include $(INCLUDE_DIR)/target.mk
 
 define Target/Description
-       Build firmware images for the AMCC Kilauea evaluation board
+       Build firmware images for AMCC/IBM PPC40x based boards.
 endef
 
 $(eval $(call BuildTarget))