ppc44x: mark as broken
[openwrt/openwrt.git] / target / linux / ppc44x / Makefile
index 47926de0eb8bbc14ab3082b9a01b232b74808a07..07404d5b47e3f8f60465cdaac38932ff550aa112 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2007-2009 OpenWrt.org
+# Copyright (C) 2007-2015 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,15 +9,18 @@ include $(TOPDIR)/rules.mk
 ARCH:=powerpc
 BOARD:=ppc44x
 BOARDNAME:=AMCC/IBM PPC44x
-FEATURES:=squashfs
+FEATURES:=squashfs broken
+CPU_TYPE:=440
+MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
-LINUX_VERSION:=2.6.30.3
-LINUX_KARCH:=powerpc
-
-include $(INCLUDE_DIR)/target.mk
+KERNEL_PATCHVER:=3.18
 
 define Target/Description
        Build firmware images for AMCC/IBM PPC44x based boards.
 endef
 
+include $(INCLUDE_DIR)/target.mk
+
+KERNELNAME:=uImage cuImage.taishan
+
 $(eval $(call BuildTarget))