layerscape: add u-boot environment support for OpenWrt boot
[openwrt/openwrt.git] / target / linux / ppc44x / Makefile
index 4a62e18247d96f8af63510c442a6b36435b17137..52772e4a8affc5d609a20e7a86db09dd4460c3a6 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2007-2012 OpenWrt.org
+# Copyright (C) 2007-2015 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,18 +9,18 @@ include $(TOPDIR)/rules.mk
 ARCH:=powerpc
 BOARD:=ppc44x
 BOARDNAME:=AMCC/IBM PPC44x
-FEATURES:=squashfs broken
-CFLAGS:=-Os -pipe -fno-caller-saves -mcpu=440
+FEATURES:=squashfs small_flash broken
+CPU_TYPE:=440
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
-LINUX_VERSION:=3.3.7
-
-include $(INCLUDE_DIR)/target.mk
-
-DEFAULT_PACKAGES := $(filter-out ppp%,$(DEFAULT_PACKAGES))
+KERNEL_PATCHVER:=3.18
 
 define Target/Description
        Build firmware images for AMCC/IBM PPC44x based boards.
 endef
 
+include $(INCLUDE_DIR)/target.mk
+
+KERNELNAME:=uImage cuImage.taishan
+
 $(eval $(call BuildTarget))