cleanup
[openwrt/openwrt.git] / target / linux / ps3 / Makefile
index 78fdfe2d70e2527a732657f0e602d50ed6d3d1c0..7412a3644fd0f2c1fe209687923c106ba93ebc98 100644 (file)
@@ -21,11 +21,13 @@ define Target/Description
        Build bootloader images for the Sony PS3 Game Console
 endef
 
+ifeq ($(CONFIG_TARGET_ps3_petitboot),y)
 # no generic patches required
 define Kernel/Prepare
        bzcat $(DL_DIR)/$(LINUX_SOURCE) | $(TAR) -C $(KERNEL_BUILD_DIR) $(TAR_OPTIONS)
        $(call PatchDir,$(PATCH_DIR),)
 endef
+endif
 
 KERNELNAME:="zImage"