ramips: move kmod-rt2800-pci to DEFAULT_PACKAGES
[openwrt/openwrt.git] / target / linux / ramips / Makefile
index 62262c656524acff78f421d2282bb2b2df57fe44..0d82260acf3664f058261d1d0d98dde24d72b1cb 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2008-2009 OpenWrt.org
+# Copyright (C) 2008-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -10,11 +10,15 @@ ARCH:=mipsel
 BOARD:=ramips
 BOARDNAME:=Ralink RT288x/RT305x
 SUBTARGETS:=rt288x rt305x
-CFLAGS:=-Os -pipe -mips32r2 -mtune=mips32r2 -funit-at-a-time
+CFLAGS:=-Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves
+FEATURES:=squashfs
 
-LINUX_VERSION:=2.6.30.6
+LINUX_VERSION:=2.6.39.4
 
 include $(INCLUDE_DIR)/target.mk
+DEFAULT_PACKAGES+=\
+       kmod-leds-gpio kmod-input-core kmod-input-polldev kmod-gpio-buttons \
+       kmod-button-hotplug kmod-rt2800-pci wpad-mini maccalc
 
 define Target/Description
        Build firmware images for Ralink RT288x/RT305x based boards.