iperf: Drop single-threaded variant
[openwrt/openwrt.git] / target / linux / ramips / Makefile
index 1265684fce0393fd47fece211e85a2edb5ef86f5..4e8b26cb8462e9c88d5de9be4502ef3ca6eb1655 100644 (file)
@@ -9,17 +9,15 @@ include $(TOPDIR)/rules.mk
 ARCH:=mipsel
 BOARD:=ramips
 BOARDNAME:=Ralink RT288x/RT3xxx
-SUBTARGETS:=rt288x rt305x rt3883
-CFLAGS:=-Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves
-FEATURES:=squashfs
+SUBTARGETS:=rt305x mt7620 mt7621 mt7628 mt7688 rt3883 rt288x
+FEATURES:=squashfs gpio mips16
+MAINTAINER:=John Crispin <john@phrozen.org>
 
-LINUX_VERSION:=3.2.13
+KERNEL_PATCHVER:=4.4
 
 include $(INCLUDE_DIR)/target.mk
-DEFAULT_PACKAGES+=\
-       kmod-leds-gpio kmod-input-core kmod-input-polldev \
-       kmod-input-gpio-keys-polled kmod-button-hotplug \
-       kmod-rt2800-pci wpad-mini maccalc
+DEFAULT_PACKAGES += \
+       kmod-leds-gpio kmod-gpio-button-hotplug wpad-mini swconfig
 
 define Target/Description
        Build firmware images for Ralink RT288x/RT3xxx based boards.