ramips: rt305x: add support for the Asus WL-330N3G board
[openwrt/openwrt.git] / target / linux / ramips / files / arch / mips / ralink / rt305x / Makefile
index ce1d5682370911817a02994413880aea2ffff522..66940cfa00f66525c2978412aa3d44865a7c35bc 100644 (file)
@@ -18,6 +18,7 @@ obj-$(CONFIG_RT305X_MACH_DIR_300_REVB)        += mach-dir-300-revb.o
 obj-$(CONFIG_RT305X_MACH_ESR_9753)     += mach-esr-9753.o
 obj-$(CONFIG_RT305X_MACH_F5D8235_V2)    += mach-f5d8235-v2.o
 obj-$(CONFIG_RT305X_MACH_FONERA20N)    += mach-fonera20n.o
+obj-$(CONFIG_RT305X_MACH_FREESTATION5)  += mach-freestation5.o
 obj-$(CONFIG_RT305X_MACH_HW550_3G)     += mach-hw550-3g.o
 obj-$(CONFIG_RT305X_MACH_MOFI3500_3GN) += mach-mofi3500-3gn.o
 obj-$(CONFIG_RT305X_MACH_NBG_419N)     += mach-nbg-419n.o
@@ -28,10 +29,14 @@ obj-$(CONFIG_RT305X_MACH_RT_G32_REVB)       += mach-rt-g32-revb.o
 obj-$(CONFIG_RT305X_MACH_RT_N10_PLUS)  += mach-rt-n10-plus.o
 obj-$(CONFIG_RT305X_MACH_SL_R7205)     += mach-sl-r7205.o
 obj-$(CONFIG_RT305X_MACH_V22RW_2X2)    += mach-v22rw-2x2.o
+obj-$(CONFIG_RT305X_MACH_W306R_V20)    += mach-w306r-v20.o
 obj-$(CONFIG_RT305X_MACH_W502U)                += mach-w502u.o
 obj-$(CONFIG_RT305X_MACH_WCR150GN)     += mach-wcr150gn.o
 obj-$(CONFIG_RT305X_MACH_WHR_G300N)    += mach-whr-g300n.o
 obj-$(CONFIG_RT305X_MACH_WR512_3GN)    += mach-wr512-3gn.o
+obj-$(CONFIG_RT305X_MACH_WL_330N)      += mach-wl-330n.o
+obj-$(CONFIG_RT305X_MACH_WL_330N3G)    += mach-wl-330n3g.o
 obj-$(CONFIG_RT305X_MACH_WL341V3)      += mach-wl341v3.o
 obj-$(CONFIG_RT305X_MACH_WL351)                += mach-wl351.o
 obj-$(CONFIG_RT305X_MACH_WR6202)       += mach-wr6202.o
+obj-$(CONFIG_RT305X_MACH_XDX_RN502J)    += mach-xdx-rn502j.o