ramips: add support for D-Link DWR-116-A1/2
[openwrt/openwrt.git] / target / linux / ramips / image / Makefile
index abcff036299bde0d70fcd95609be39efcb5e8a59..13934c5b060ea5f949c4581cc2fd33bcb6f4b76f 100644 (file)
@@ -111,6 +111,26 @@ define Build/wrg-header
        mv $@.new $@
 endef
 
        mv $@.new $@
 endef
 
+# combine kernel and rootfs into one image
+# mkdlinkfw <type> <optional extra arguments to mkdlinkfw binary>
+
+define Build/mkdlinkfw
+       -$(STAGING_DIR_HOST)/bin/mkdlinkfw \
+               -k $(IMAGE_KERNEL) \
+               -r $(IMAGE_ROOTFS) \
+               -o $@ \
+               -s $(DLINK_FIRMWARE_SIZE)
+endef
+
+define Build/mkdlinkfw-factory
+       -$(STAGING_DIR_HOST)/bin/mkdlinkfw \
+               -m $(DLINK_ROM_ID) -f $(DLINK_FAMILY_MEMBER) \
+               -F $@ \
+               -o $@.new \
+               -s $(DLINK_FIRMWARE_SIZE)
+       mv $@.new $@
+endef
+
 #
 # The real magic happens inside these templates
 #
 #
 # The real magic happens inside these templates
 #