ramips: fix legacy initramfs images
[openwrt/openwrt.git] / target / linux / ramips / image / Makefile
index ef30c79a4e76932f4688c54f6992d75edb201589..7b53a2f7442fcfaa92d208d1fab5240cb1fd036c 100644 (file)
@@ -300,6 +300,7 @@ define Image/Build
 endef
 
 define Image/Build/Profile
 endef
 
 define Image/Build/Profile
+       $(if $(CONFIG_TARGET_ROOTFS_INITRAMFS),$(call Image/Build/Profile/$(1),initramfs))
        $(call Image/Build/Profile/$(1),$(2))
 endef
 
        $(call Image/Build/Profile/$(1),$(2))
 endef