ramips: add support for Planex MZK-WDPR.
[openwrt/openwrt.git] / target / linux / ramips / image / Makefile
index eb50cddeaf75b772729f1e76ddc1e1001432766a..e85c57470b4a173d372f513515b76489184ef190 100644 (file)
@@ -631,6 +631,8 @@ Image/Build/Profile/NBG-419N=$(call BuildFirmware/Default4M/$(1),$(1),nbg-419n,N
 
 Image/Build/Profile/MZKW300NH2=$(call BuildFirmware/Edimax/$(1),$(1),mzk-w300nh2,MZK-W300NH2,$(mzkw300nh2_mtd_size),CSYS,RN52,0x50000,0xc0000)
 
+Image/Build/Profile/MZKWDPR=$(call BuildFirmware/Default8M/$(1),$(1),mzk-wdpr,MZK-WDPR)
+
 Image/Build/Profile/NCS601W=$(call BuildFirmware/Default8M/$(1),$(1),ncs601W,NCS601W)
 
 nw718_mtd_size=3801088
@@ -817,6 +819,7 @@ define Image/Build/Profile/Default
        $(call Image/Build/Profile/MPRA1,$(1))
        $(call Image/Build/Profile/MPRA2,$(1))
        $(call Image/Build/Profile/MZKW300NH2,$(1))
+       $(call Image/Build/Profile/MZKWDPR,$(1))
        $(call Image/Build/Profile/NBG-419N,$(1))
        $(call Image/Build/Profile/NCS601W,$(1))
        $(call Image/Build/Profile/NW718,$(1))
@@ -1115,9 +1118,10 @@ define Device/wf-2881
   DTS := WF-2881
   BLOCKSIZE := 128KiB
   PAGESIZE := 2048
-  KERNEL_SIZE := 2097152
   FILESYSTEMS := squashfs
-  IMAGE/sysupgrade.bin := append-kernel | pad-to $$(KERNEL_SIZE) | append-ubi | check-size $$$$(IMAGE_SIZE)
+  IMAGE_SIZE := 132382720
+  KERNEL := $(KERNEL_DTB) | pad-offset 131072 64 | uImage lzma
+  IMAGE/sysupgrade.bin := append-kernel | append-ubi | check-size $$$$(IMAGE_SIZE)
 endef
 
 define Device/ubnt-erx