ramips: move umedia build step to Makefile
[openwrt/openwrt.git] / target / linux / ramips / image / Makefile
index 6116a53bf2bffeb2358769f41787e6901a862066..ef30c79a4e76932f4688c54f6992d75edb201589 100644 (file)
@@ -74,6 +74,10 @@ define MkCombineduImage
        $(call MkImage,lzma,$(KDIR)/vmlinux-$(2).bin.lzma.combined,$(call sysupname,$(1),$(2)),$(6))
 endef
 
+define Build/umedia-header
+       fix-u-media-header -T 0x46 -B $(1) -i $@ -o $@.new && mv $@.new $@
+endef
+
 #
 # The real magic happens inside these templates
 #