ramips: split Phicomm PSG1218 and PSG1218K2C
[openwrt/openwrt.git] / target / linux / ramips / image / mt7620.mk
index 7122cfdff5b61ad35071e5cd9142cb6fbec56114..63d5a7c00afa74271cf1bc6aed449b48d604e952 100644 (file)
@@ -325,10 +325,17 @@ TARGET_DEVICES += psg1208
 define Device/psg1218
   DTS := PSG1218
   DEVICE_TITLE := Phicomm PSG1218
-  DEVICE_PACKAGES := kmod-mt76
+  DEVICE_PACKAGES := kmod-mt76x2
 endef
 TARGET_DEVICES += psg1218
 
+define Device/psg1218k2c
+  DTS := PSG1218K2C
+  DEVICE_TITLE := Phicomm PSG1218K2C
+  DEVICE_PACKAGES := kmod-mt76x2
+endef
+TARGET_DEVICES += psg1218k2c
+
 define Device/rp-n53
   DTS := RP-N53
   DEVICE_TITLE := Asus RP-N53
@@ -467,6 +474,12 @@ define Device/zbt-wa05
 endef
 TARGET_DEVICES += zbt-wa05
 
+define Device/zbt-we2026
+  DTS := ZBT-WE2026
+  DEVICE_TITLE := Zbtlink ZBT-WE2026
+endef
+TARGET_DEVICES += zbt-we2026
+
 define Device/zbt-we826
   DTS := ZBT-WE826
   IMAGE_SIZE := $(ralink_default_fw_size_16M)