ramips: add support for Asus RT-N11P / RT-N12+ / RT-N12E b1
[openwrt/openwrt.git] / target / linux / ramips / image / mt7620.mk
index 796cc619a3a673be6f8b7eb6ab6726287dc13368..a55cc8214bee7dc561ef7b7c7c1aa8bcd8589b55 100644 (file)
@@ -105,7 +105,9 @@ TARGET_DEVICES += cf-wr800n
 define Device/cs-qr10
   DTS := CS-QR10
   DEVICE_TITLE := Planex CS-QR10
-  DEVICE_PACKAGES := kmod-usb2 kmod-usb-ohci kmod-i2c-core kmod-i2c-ralink kmod-sound-core kmod-sound-mtk kmod-sdhci-mt7620
+  DEVICE_PACKAGES := kmod-usb2 kmod-usb-ohci \
+       kmod-sound-core kmod-sound-mt7620 \
+       kmod-i2c-ralink kmod-sdhci-mt7620
 endef
 TARGET_DEVICES += cs-qr10
 
@@ -139,7 +141,7 @@ define Device/dch-m225
        seama-seal -m "signature=wapn22_dlink.2013gui_dap1320b" | \
        check-size $$$$(IMAGE_SIZE)
   DEVICE_TITLE := D-Link DCH-M225
-  DEVICE_PACKAGES := kmod-mt76
+  DEVICE_PACKAGES := kmod-mt76 kmod-sound-core kmod-sound-mt7620 kmod-i2c-ralink
 endef
 TARGET_DEVICES += dch-m225
 
@@ -389,6 +391,12 @@ define Device/rp-n53
 endef
 TARGET_DEVICES += rp-n53
 
+define Device/rt-n12p
+  DTS := RT-N12-PLUS
+  DEVICE_TITLE := Asus RT-N11P/RT-N12+/RT-N12Eb1
+endef
+TARGET_DEVICES += rt-n12p
+
 define Device/rt-n14u
   DTS := RT-N14U
   DEVICE_TITLE := Asus RT-N14u