ramips: add support for the YouHua WR1200JS
[openwrt/openwrt.git] / target / linux / ramips / image / mt7621.mk
index 18b6934529e3883276e2b8fa8dc00a098ca0f73a..d78175cf74d6ae754a1f6396ed0a1cb2303cc7fd 100644 (file)
@@ -328,6 +328,15 @@ define Device/wndr3700v5
 endef
 TARGET_DEVICES += wndr3700v5
 
+define Device/youhua_wr1200js
+  DTS := WR1200JS
+  IMAGE_SIZE := 16064k
+  DEVICE_TITLE := YouHua WR1200JS
+  DEVICE_PACKAGES := \
+       kmod-mt7603 kmod-mt76x2 kmod-usb3 kmod-usb-ledtrig-usbport
+endef
+TARGET_DEVICES += youhua_wr1200js
+
 define Device/wsr-1166
   DTS := WSR-1166
   IMAGE/sysupgrade.bin := trx | pad-rootfs | append-metadata