ramips: add support for TP-Link MR6400 v5
[openwrt/openwrt.git] / target / linux / ramips / image / mt76x8.mk
index 30c41420aa5cdc4cfa4f8559b87690eb6f165132..72539f7a14d90378731c219a38049103c65aec57 100644 (file)
@@ -498,6 +498,22 @@ define Device/tplink_tl-mr6400-v4
 endef
 TARGET_DEVICES += tplink_tl-mr6400-v4
 
 endef
 TARGET_DEVICES += tplink_tl-mr6400-v4
 
+define Device/tplink_tl-mr6400-v5
+  $(Device/tplink-v2)
+  IMAGE_SIZE := 7808k
+  DEVICE_MODEL := TL-MR6400
+  DEVICE_VARIANT := v5
+  TPLINK_FLASHLAYOUT := 8Mmtk
+  TPLINK_HWID := 0x64000005
+  TPLINK_HWREV := 0x5
+  TPLINK_HWREVADD := 0x5
+  DEVICE_PACKAGES := kmod-usb2 kmod-usb-ohci kmod-usb-ledtrig-usbport \
+       kmod-usb-serial kmod-usb-serial-option kmod-usb-net-qmi-wwan uqmi
+  IMAGES := sysupgrade.bin tftp-recovery.bin
+  IMAGE/tftp-recovery.bin := pad-extra 128k | $$(IMAGE/factory.bin)
+endef
+TARGET_DEVICES += tplink_tl-mr6400-v5
+
 define Device/tplink_tl-wa801nd-v5
   $(Device/tplink-v2)
   IMAGE_SIZE := 7808k
 define Device/tplink_tl-wa801nd-v5
   $(Device/tplink-v2)
   IMAGE_SIZE := 7808k