ramips: add support for D-Link DAP-1325-A1
[openwrt/openwrt.git] / target / linux / ramips / image / mt76x8.mk
index 3f738fc48844577936d52fc7eeadb6f9466a8626..7862f7b7998742ace3c743603d8ee18a7a2ee2f1 100644 (file)
@@ -100,6 +100,13 @@ define Device/d-team_pbr-d1
 endef
 TARGET_DEVICES += d-team_pbr-d1
 
+define Device/dlink_dap-1325-a1
+  IMAGE_SIZE := 7872k
+  DEVICE_VENDOR := D-Link
+  DEVICE_MODEL := DAP-1325 A1
+endef
+TARGET_DEVICES += dlink_dap-1325-a1
+
 define Device/duzun_dm06
   IMAGE_SIZE := 7872k
   DEVICE_VENDOR := DuZun
@@ -274,9 +281,18 @@ define Device/minew_g1-c
   DEVICE_VENDOR := Minew
   DEVICE_MODEL := G1-C
   DEVICE_PACKAGES := kmod-usb2 kmod-usb-ohci kmod-usb-ledtrig-usbport kmod-usb-serial-cp210x
+  SUPPORTED_DEVICES += minew-g1c
 endef
 TARGET_DEVICES += minew_g1-c
 
+define Device/motorola_mwr03
+  IMAGE_SIZE := 7872k
+  DEVICE_VENDOR := Motorola
+  DEVICE_MODEL := MWR03
+  DEVICE_PACKAGES := kmod-mt76x2
+endef
+TARGET_DEVICES += motorola_mwr03
+
 define Device/netgear_r6020
   $(Device/netgear_sercomm_nor)
   IMAGE_SIZE := 7104k