ramips: use new image build code for D-Link DCS-930 family
[openwrt/openwrt.git] / target / linux / ramips / image / rt305x-legacy.mk
index 173739b0737cdd53fa6d78b98b604ce67a0ae6e4..f5a892d3655b368557484d421b985909dd25b90a 100644 (file)
@@ -1,58 +1,6 @@
 #
 # RT305X Profiles
 #
-define BuildFirmware/DCS930/squashfs
-       $(call BuildFirmware/Default4M/squashfs,squashfs,$(2),$(3))
-       dd if=$(KDIR)/vmlinux-$(2).bin.lzma of=$(KDIR)/image.$(2).combined bs=1048512 count=1 conv=sync
-       cat $(KDIR)/root.squashfs >> $(KDIR)/image.$(2).combined
-       $(call MkImage,lzma,$(KDIR)/image.$(2).combined,$(KDIR)/image.$(2))
-       $(call prepare_generic_squashfs,$(KDIR)/image.$(2))
-       if [ `stat -c%s "$(KDIR)/image.$(2)"` -gt $(ralink_default_fw_size_4M) ]; then \
-               echo "Warning: $(KDIR)/image.$(2)  is too big" >&2; \
-       else \
-               dd if=$(KDIR)/image.$(2) of=$(KDIR)/dcs.tmp bs=64K count=5 conv=sync ;\
-               cat $(KDIR)/image.$(2) >> $(KDIR)/dcs.tmp ; \
-               dd if=$(KDIR)/dcs.tmp of=$(call imgname,$(1),$(2))-factory.bin bs=4096k count=1 conv=sync ;\
-               $(STAGING_DIR_HOST)/bin/mkdcs932 $(call imgname,$(1),$(2))-factory.bin ; \
-       fi
-endef
-BuildFirmware/DCS930/initramfs=$(call BuildFirmware/OF/initramfs,$(1),$(2),$(3))
-
-# sign Buffalo images
-define BuildFirmware/Buffalo
-       if [ -e "$(call sysupname,$(1),$(2))" ]; then \
-               buffalo-enc -p $(3) -v 1.76 \
-                       -i $(KDIR)/vmlinux-$(2).uImage \
-                       -o $(KDIR)/vmlinux-$(2).uImage.enc; \
-               buffalo-enc -p $(3) -v 1.76 \
-                       -i $(KDIR)/root.$(1) \
-                       -o $(KDIR)/root.$(2).enc; \
-               buffalo-tag -b $(3) -p $(3) -a ram -v 1.76 -m 1.01 \
-                       -l mlang8 -f 1 -r EU \
-                       -i $(KDIR)/vmlinux-$(2).uImage.enc \
-                       -i $(KDIR)/root.$(2).enc \
-                       -o $(call imgname,$(1),$(2))-factory-EU.bin; \
-       fi
-endef
-
-# FIXME: this looks broken
-buffalo_whrg300n_mtd_size=3801088
-define BuildFirmware/WHRG300N/squashfs
-       $(call BuildFirmware/Default4M/$(1),$(1),whr-g300n,WHR-G300N)
-       # the following line has a bad argument 3 ... the old Makefile was already broken       
-       $(call BuildFirmware/Buffalo,$(1),whr-g300n,whr-g300n)
-       if [ -e "$(call sysupname,$(1),$(2))" ]; then \
-               ( \
-                       echo -n -e "# Airstation FirmWare\nrun u_fw\nreset\n\n" | \
-                               dd bs=512 count=1 conv=sync; \
-                       dd if=$(call sysupname,$(1),whr-g300n); \
-               ) > $(KDIR)/whr-g300n-tftp.tmp && \
-               buffalo-tftp -i $(KDIR)/whr-g300n-tftp.tmp \
-                       -o $(call imgname,$(1),whr-g300n)-tftp.bin; \
-       fi
-endef
-BuildFirmware/WHRG300N/initramfs=$(call BuildFirmware/OF/initramfs,$(1),whr-g300n,WHR-G300N)
-
 kernel_size_wl341v3=917504
 rootfs_size_wl341v3=2949120
 define BuildFirmware/WL-341V3/squashfs
@@ -81,10 +29,7 @@ define Image/Build/Profile/ALL02393G
        $(call Image/Build/Template/$(image_type)/$(1),UIMAGE_8M,all0239-3g,ALL0239-3G,ttyS1,57600,phys)
 endef
 
-Image/Build/Profile/DCS930=$(call BuildFirmware/DCS930/$(1),$(1),dcs-930,DCS-930)
-Image/Build/Profile/DCS930LB1=$(call BuildFirmware/DCS930/$(1),$(1),dcs-930l-b1,DCS-930L-B1)
 Image/Build/Profile/WL-341V3=$(call BuildFirmware/WL-341V3/$(1),$(1))
-Image/Build/Profile/WHRG300N=$(call BuildFirmware/WHRG300N/$(1),$(1))
 
 define LegacyDevice/ALL02393G
   DEVICE_TITLE := Allnet ALL0239-3G 
@@ -92,27 +37,7 @@ define LegacyDevice/ALL02393G
 endef
 LEGACY_DEVICES += ALL02393G
 
-
-define LegacyDevice/DCS930
-  DEVICE_TITLE := D-Link DCS-930
-  DEVICE_PACKAGES := kmod-video-core kmod-video-uvc kmod-sound-core kmod-usb-audio kmod-usb-core kmod-usb-dwc2
-endef
-LEGACY_DEVICES += DCS930
-
-
-define LegacyDevice/DCS930LB1
-  DEVICE_TITLE := D-Link DCS-930L B1
-  DEVICE_PACKAGES := kmod-video-core kmod-video-uvc kmod-sound-core kmod-usb-audio kmod-usb-core kmod-usb-ohci kmod-usb2
-endef
-LEGACY_DEVICES += DCS930LB1
-
 define LegacyDevice/WL-341V3
   DEVICE_TITLE := Sitecom WL-341 v3
 endef
 LEGACY_DEVICES += WL-341V3
-
-
-define LegacyDevice/WHRG300N
-  DEVICE_TITLE := Buffalo WHR-G300N
-endef
-LEGACY_DEVICES += WHRG300N