ramips: fix subtarget kernel version assignment (only mt7621 is ready for now)
[openwrt/openwrt.git] / target / linux / ramips / mt7621 / target.mk
index 830b5b098d7655722df5952c223b120e33b3bf90..a0a7afc969d4ce6e23ada83624dc657018d4a884 100644 (file)
@@ -4,12 +4,15 @@
 
 SUBTARGET:=mt7621
 BOARDNAME:=MT7621 based boards
-ARCH_PACKAGES:=ramips_24kec
+ARCH_PACKAGES:=ramips_1004kc
 FEATURES+=usb
-CPU_TYPE:=24kec
+CPU_TYPE:=1004kc
 CPU_SUBTYPE:=dsp
+CFLAGS:=-Os -pipe -mmt -mips32r2 -mtune=1004kc
 
-DEFAULT_PACKAGES += kmod-rt2800-pci
+DEFAULT_PACKAGES += kmod-mt76
+
+KERNEL_PATCHVER:=4.4
 
 define Target/Description
        Build firmware images for Ralink MT7621 based boards.