Remove patch-cmdline from the packages and move it tools tools/. adm5120 and rb532...
[openwrt/openwrt.git] / target / linux / rb532-2.6 / image / Makefile
index 149a7e27344cb881e566ca90cab34b9c4fca1767..555eb2a645cd841be61009a71de6af3c644c317b 100644 (file)
@@ -20,10 +20,6 @@ LOADER_MAKEOPTS= \
                RAMSIZE=$(RAMSIZE) \
                IMAGE_COPY=$(IMAGE_COPY)
 
-define Build/Compile
-       $(CC) -o $(STAGING_DIR)/bin/patch-cmdline $(PLATFORM_DIR)/src/patch-cmdline.c
-endef
-
 define Build/Clean
        $(MAKE) -C $(GENERIC_PLATFORM_DIR)/image/lzma-loader $(LOADER_MAKEOPTS) clean
 endef
@@ -49,6 +45,10 @@ define Image/cmdline/ext2
 root=/dev/cfa2 rootfstype=ext2 init=/etc/preinit
 endef
 
+define Image/cmdline/squashfs
+block2mtd.block2mtd=/dev/cfa2,65536 root=/dev/mtdblock0 rootfstype=squashfs init=/etc/preinit
+endef
+
 define Image/Build
        $(STAGING_DIR)/bin/patch-cmdline $(KDIR)/vmlinux.elf '$(strip $(call Image/cmdline/$(1))) '
        ./gen_image.sh $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(1).bin 4 $(KDIR)/vmlinux.elf $(CONFIG_TARGET_ROOTFS_FSPART) $(KDIR)/root.$(1)