sunxi: add support for kernel 4.9
[openwrt/openwrt.git] / target / linux / sunxi / Makefile
index aa9901766ee9dc8e87f06dfa5cf484360b0f4312..483c9eb21cd897b0cd4050e867ff7e411ef7a2e9 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2013-2014 OpenWrt.org
+# Copyright (C) 2013-2016 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -10,20 +10,24 @@ include $(TOPDIR)/rules.mk
 ARCH:=arm
 BOARD:=sunxi
 BOARDNAME:=Allwinner A1x/A20/A3x
-FEATURES:=fpu usb ext4 display rtc
+FEATURES:=fpu usb ext4 display rtc squashfs
 CPU_TYPE:=cortex-a8
 CPU_SUBTYPE:=vfpv3
 MAINTAINER:=Zoltan HERPAI <wigyori@uid0.hu>
 
-LINUX_VERSION:=3.13.7
-KERNELNAME:="zImage dtbs"
-DEFAULT_PACKAGES += uboot-envtools uboot-sunxi kmod-eeprom-sunxi kmod-wdt-sunxi
+KERNEL_PATCHVER:=4.9
+KERNELNAME:=zImage dtbs
 
 # A10: Cortex-A8
 # A13: Cortex-A8
 # A20: dual Cortex-A7
 # A31: quad Cortex-A7
+# A80: octa Cortex-A15/A7
+# H3: quad Cortex-A7
 
 include $(INCLUDE_DIR)/target.mk
 
+DEFAULT_PACKAGES += uboot-envtools
+DEFAULT_PACKAGES += partx-utils mkf2fs e2fsprogs
+
 $(eval $(call BuildTarget))