prepare for the transition to linux 2.6.22 - make it possible to override the kernel...
[openwrt/openwrt.git] / target / linux / x86-2.6 / Makefile
index 25e7356877c8a8df667c8ea7bf359c897c30a860..06decc151fa50a3ec3f99e992c4b75db2406842a 100644 (file)
@@ -9,9 +9,16 @@ include $(TOPDIR)/rules.mk
 ARCH=i386
 BOARD:=x86
 BOARDNAME:=x86
-FEATURES:=jffs2 ext2
+FEATURES:=squashfs jffs2 ext2
+
+#LINUX_VERSION:=2.6.22-rc4
+#LINUX_KERNEL_MD5SUM:=125879208b47a4c27e4f31a33ab3011c
 
 include $(INCLUDE_DIR)/kernel-build.mk
+DEFAULT_PACKAGES += kmod-natsemi kmod-ne2k-pci
+
+# include the profiles
+-include profiles/*.mk
 
 $(eval $(call BuildKernel))