cleanup/rewrite of the kernel build process
[openwrt/openwrt.git] / target / linux / x86-2.6 / Makefile
index 5dc19cf679161e43c9f3f86f2112a6146a6a891b..323eb2c3f4103b8cfc2e6af7356d1db94a166084 100644 (file)
@@ -10,11 +10,5 @@ LINUX_VERSION:=2.6.17
 LINUX_RELEASE:=1
 LINUX_KERNEL_MD5SUM:=37ddefe96625502161f075b9d907f21e
 
-include ./config
 include $(INCLUDE_DIR)/kernel-build.mk
-
-$(LINUX_DIR)/.patched: $(LINUX_DIR)/.unpacked
-       [ -d ../generic-$(KERNEL)/patches ] && $(PATCH) $(LINUX_DIR) ../generic-$(KERNEL)/patches
-       [ -d ./patches ] && $(PATCH) $(LINUX_DIR) ./patches
-       @$(CP) config $(LINUX_DIR)/.config
-       touch $@
+$(eval $(call BuildKernel))