x86: remove the ep80579 subtarget, it has been unmaintained for a long time
[openwrt/openwrt.git] / target / linux / x86 / Makefile
index d1056109b97496a9e6e21e40f4962c5b4d6377cf..1e51d7117e97b0e5939e5e47542b1788cd5bc4fa 100644 (file)
@@ -1,21 +1,25 @@
 #
-# Copyright (C) 2006-2008 OpenWrt.org
+# Copyright (C) 2006-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
 include $(TOPDIR)/rules.mk
 
-ARCH=i386
+ARCH:=i386
 BOARD:=x86
 BOARDNAME:=x86
-FEATURES:=squashfs jffs2 ext2 vdi vmdk tgz
-SUBTARGETS=generic
+FEATURES:=squashfs ext4 vdi vmdk pcmcia targz
+SUBTARGETS=generic xen_domu geode kvm_guest 64
+MAINTAINER:=Felix Fietkau <nbd@openwrt.org>
 
-LINUX_VERSION:=2.6.28.9
+DEFAULT_PACKAGES += partx-utils
+
+KERNEL_PATCHVER:=4.4
+
+KERNELNAME:=bzImage
 
 include $(INCLUDE_DIR)/target.mk
-DEFAULT_PACKAGES += kmod-natsemi kmod-ne2k-pci
 
 $(eval $(call BuildTarget))