x86: remove the kvm_guest subtarget
[openwrt/openwrt.git] / target / linux / x86 / Makefile
index 8aa3996bb1ff64d2337ad6978443aeb34e926150..1eae227f858fadfd463e84c7a63e73d024f6fb54 100644 (file)
@@ -1,21 +1,25 @@
 #
-# Copyright (C) 2006-2008 OpenWrt.org
+# Copyright (C) 2006-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
 include $(TOPDIR)/rules.mk
 
-ARCH=i386
+ARCH:=i386
 BOARD:=x86
 BOARDNAME:=x86
-FEATURES:=squashfs jffs2 ext2 vdi
-SUBTARGETS=generic
+FEATURES:=squashfs ext4 vdi vmdk pcmcia targz
+SUBTARGETS=generic xen_domu geode 64
+MAINTAINER:=Felix Fietkau <nbd@openwrt.org>
 
-LINUX_VERSION:=2.6.25.6
+DEFAULT_PACKAGES += partx-utils
+
+KERNEL_PATCHVER:=4.4
+
+KERNELNAME:=bzImage
 
 include $(INCLUDE_DIR)/target.mk
-DEFAULT_PACKAGES += kmod-natsemi kmod-ne2k-pci
 
 $(eval $(call BuildTarget))