omap: remove linux 4.9 support
[openwrt/openwrt.git] / target / linux / x86 / Makefile
index 3288de347a08acbf62582f18261567cebe568025..533c0e524807ec452175fbdafcedfc05e1c28c83 100644 (file)
@@ -1,21 +1,25 @@
 #
-# Copyright (C) 2006-2008 OpenWrt.org
+# Copyright (C) 2006-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
 include $(TOPDIR)/rules.mk
 
-ARCH=i386
+ARCH:=i386
 BOARD:=x86
 BOARDNAME:=x86
-FEATURES:=squashfs jffs2 ext2 vdi
-SUBTARGETS=generic
+FEATURES:=squashfs ext4 vdi vmdk pcmcia targz fpu
+SUBTARGETS:=generic legacy geode 64
+MAINTAINER:=Felix Fietkau <nbd@nbd.name>
 
-LINUX_VERSION:=2.6.25.16
+KERNEL_PATCHVER:=4.14
+
+KERNELNAME:=bzImage
 
 include $(INCLUDE_DIR)/target.mk
-DEFAULT_PACKAGES += kmod-natsemi kmod-ne2k-pci
+
+DEFAULT_PACKAGES += partx-utils mkf2fs e2fsprogs
 
 $(eval $(call BuildTarget))