x86: merge all geode based subtargets into one
[openwrt/openwrt.git] / target / linux / x86 / Makefile
index afff2c6a6af5a99fc8fe88e0790028d34d9c428a..b5164d81ec993842123297a9fc33bbce40297ec5 100644 (file)
@@ -1,21 +1,22 @@
 #
-# Copyright (C) 2006-2008 OpenWrt.org
+# Copyright (C) 2006-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
 include $(TOPDIR)/rules.mk
 
-ARCH=i386
+ARCH:=i386
 BOARD:=x86
 BOARDNAME:=x86
-FEATURES:=squashfs jffs2 ext2
-SUBTARGETS=generic mediacenter
+FEATURES:=squashfs ext4 vdi vmdk pcmcia targz
+SUBTARGETS=generic olpc xen_domu ep80579 geode kvm_guest rdc
 
-LINUX_VERSION:=2.6.23.16
+KERNEL_PATCHVER:=3.18
+
+KERNELNAME:=bzImage
 
 include $(INCLUDE_DIR)/target.mk
-DEFAULT_PACKAGES += kmod-natsemi kmod-ne2k-pci
 
 $(eval $(call BuildTarget))