move most of the x86 image generation options to the main file
[openwrt/openwrt.git] / target / linux / x86 / image / Makefile
index 2a6a2e336d92d86abadea5a9706f735704cae1e4..4b40e64de782e54010033423c69028edf37724aa 100644 (file)
@@ -1,5 +1,5 @@
 # 
-# Copyright (C) 2006-2010 OpenWrt.org
+# Copyright (C) 2006-2012 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,42 +9,47 @@ include $(INCLUDE_DIR)/image.mk
 
 export PATH=$(TARGET_PATH):/sbin
 
-ifneq ($(CONFIG_TARGET_x86_olpc),y)
-BOOTOPTS=$(strip $(subst ",, $(CONFIG_X86_GRUB_BOOTOPTS)))
-ROOTPART=$(strip $(subst ",, $(CONFIG_X86_GRUB_ROOTPART)))
-#"))")) # fix vim's broken syntax highlighting
-endif
-
-ifeq ($(CONFIG_TARGET_x86_olpc),y)
-ROOTPART=$(strip $(subst ",, $(CONFIG_OLPC_BOOTSCRIPT_ROOTPART)))
-endif
-#"))")) # fix vim's broken syntax highlighting
-
+GRUB2_MODULES = biosdisk boot chain configfile ext2 linux ls part_msdos reboot serial vga
+GRUB2_MODULES_ISO = biosdisk boot chain configfile iso9660 linux ls part_msdos reboot serial vga
 GRUB_TERMINALS =
 GRUB_SERIAL_CONFIG =
 GRUB_TERMINAL_CONFIG =
 GRUB_CONSOLE_CMDLINE =
 
-ifeq ($(CONFIG_X86_GRUB_CONSOLE),y)
-GRUB_CONSOLE_CMDLINE += console=tty0
-GRUB_TERMINALS += console
+USE_ATKBD = generic kvm_guest
+
+ifneq ($(strip $(foreach subtarget,$(USE_ATKBD),$(CONFIG_TARGET_x86_$(subtarget)))),)
+  GRUB2_MODULES += at_keyboard
+  GRUB2_MODULES_ISO += at_keyboard
 endif
 
-ifneq ($(CONFIG_X86_GRUB_SERIAL),)
-GRUB_CONSOLE_CMDLINE += console=$(strip $(subst ",, $(CONFIG_X86_GRUB_SERIAL))),$(CONFIG_X86_GRUB_BAUDRATE)n8
-GRUB_SERIAL_CONFIG = serial --unit=0 --speed=$(CONFIG_X86_GRUB_BAUDRATE) --word=8 --parity=no --stop=1
-GRUB_TERMINALS += serial
+ifneq ($(CONFIG_GRUB_CONSOLE),)
+  GRUB_CONSOLE_CMDLINE += console=tty0
+  GRUB_TERMINALS += console
+endif
+
+GRUB_SERIAL:=$(call qstrip,$(CONFIG_GRUB_SERIAL))
+
+ifneq ($(GRUB_SERIAL),)
+  GRUB_CONSOLE_CMDLINE += console=$(GRUB_SERIAL),$(CONFIG_GRUB_BAUDRATE)n8
+  GRUB_SERIAL_CONFIG := serial --unit=0 --speed=$(CONFIG_GRUB_BAUDRATE) --word=8 --parity=no --stop=1
+  GRUB_TERMINALS += serial
 endif
 
 ifneq ($(GRUB_TERMINALS),)
-GRUB_TERMINAL_CONFIG = terminal --timeout=2 $(GRUB_TERMINALS)
+  GRUB_TERMINAL_CONFIG := terminal_input $(GRUB_TERMINALS); terminal_output $(GRUB_TERMINALS)
 endif
 
+ROOTPART:=$(call qstrip,$(CONFIG_TARGET_ROOTFS_PARTNAME))
 
-ifeq ($(CONFIG_X86_GRUB_IMAGES),y)
-ifneq ($(HOST_OS),Darwin)
-  define Image/cmdline/squashfs
-    block2mtd.block2mtd=$(ROOTPART),65536,rootfs root=/dev/mtdblock0 rootfstype=squashfs rootwait
+GRUB_TIMEOUT:=$(call qstrip,$(CONFIG_GRUB_TIMEOUT))
+
+ifneq ($(CONFIG_GRUB_IMAGES),)
+
+  BOOTOPTS:=$(call qstrip,$(CONFIG_GRUB_BOOTOPTS))
+
+  define Image/cmdline/ext4
+    root=$(ROOTPART) rootfstype=ext4 rootwait
   endef
 
   define Image/cmdline/jffs2-64k
@@ -55,67 +60,48 @@ ifneq ($(HOST_OS),Darwin)
     block2mtd.block2mtd=$(ROOTPART),131072,rootfs root=/dev/mtdblock0 rootfstype=jffs2 rootwait
   endef
 
-  define Image/cmdline/ext2
-    root=$(ROOTPART) rootfstype=ext2 rootwait
+  define Image/cmdline/squashfs
+    block2mtd.block2mtd=$(ROOTPART),65536,rootfs root=/dev/mtdblock0 rootfstype=squashfs rootwait
   endef
-  
-  define Image/Build/grub
+
+  define Image/Build/grub2
        # left here because the image builder doesnt need these
-       $(INSTALL_DIR) $(KDIR)/root.grub/boot/grub
-       $(CP) \
-               $(KDIR)/*stage* \
-               $(KDIR)/root.grub/boot/grub/
+       $(INSTALL_DIR) $(KDIR)/root.grub/boot/grub $(KDIR)/grub2
        $(CP) $(KDIR)/bzImage $(KDIR)/root.grub/boot/vmlinuz
+       grub-mkimage \
+               -d $(STAGING_DIR_HOST)/lib/grub/i386-pc \
+               -o $(KDIR)/grub2/core.img \
+               -O i386-pc \
+               -c ./grub-early.cfg \
+               $(GRUB2_MODULES)
+       $(CP) $(STAGING_DIR_HOST)/lib/grub/i386-pc/*.img $(KDIR)/grub2/
+       echo '(hd0) $(BIN_DIR)/$(IMG_PREFIX)-combined-$(1).img' > $(KDIR)/grub2/device.map
        sed \
                -e 's#@SERIAL_CONFIG@#$(strip $(GRUB_SERIAL_CONFIG))#g' \
                -e 's#@TERMINAL_CONFIG@#$(strip $(GRUB_TERMINAL_CONFIG))#g' \
                -e 's#@CMDLINE@#$(strip $(call Image/cmdline/$(1)) $(BOOTOPTS) $(GRUB_CONSOLE_CMDLINE))#g' \
-               ./menu.lst > $(KDIR)/root.grub/boot/grub/menu.lst
-       PADDING="$(CONFIG_X86_GRUB_IMAGES_PAD)" PATH="$(TARGET_PATH)" ./gen_image_x86.sh $(BIN_DIR)/$(IMG_PREFIX)-$(1).image $(CONFIG_X86_GRUB_KERNELPART) $(KDIR)/root.grub $(CONFIG_TARGET_ROOTFS_FSPART) $(KDIR)/root.$(1)
+               -e 's#@TIMEOUT@#$(GRUB_TIMEOUT)#g' \
+               ./grub.cfg > $(KDIR)/root.grub/boot/grub/grub.cfg
+       PADDING="$(CONFIG_TARGET_IMAGES_PAD)" PATH="$(TARGET_PATH)" ./gen_image_generic.sh \
+               $(BIN_DIR)/$(IMG_PREFIX)-combined-$(1).img \
+               $(CONFIG_TARGET_KERNEL_PARTSIZE) $(KDIR)/root.grub \
+               $(CONFIG_TARGET_ROOTFS_PARTSIZE) $(KDIR)/root.$(1) \
+               256
+       grub-bios-setup \
+               --device-map="$(KDIR)/grub2/device.map" \
+               -d "$(KDIR)/grub2" \
+               -r "hd0,msdos1" \
+               "$(BIN_DIR)/$(IMG_PREFIX)-combined-$(1).img"
        $(call Image/Build/grub/$(1))
   endef
-
-  define Image/Prepare/grub
-       # for the image builder
-       $(CP) \
-               $(STAGING_DIR_HOST)/usr/lib/grub/i386-*/stage1 \
-               $(STAGING_DIR_HOST)/usr/lib/grub/i386-*/stage2 \
-               $(STAGING_DIR_HOST)/usr/lib/grub/i386-*/e2fs_stage1_5 \
-               $(KDIR)/
-  endef
-else
-  define Image/Build/grub
-       PADDING="$(CONFIG_X86_GRUB_IMAGES_PAD)" PATH="$(TARGET_PATH)" NOGRUB=1 ./gen_image_x86.sh $(BIN_DIR)/$(IMG_PREFIX)-$(1).image $(CONFIG_X86_GRUB_KERNELPART) "" $(CONFIG_TARGET_ROOTFS_FSPART) $(KDIR)/root.$(1)
-  endef
-endif
-endif
-
-ifeq ($(CONFIG_X86_VDI_IMAGES),y)
-  define Image/Build/vdi
-    # left here because the image builder doesnt need these
-    ifeq ($(1),ext2)
-               rm $(BIN_DIR)/$(IMG_PREFIX)-ext2.vdi || true
-               VBoxManage convertfromraw -format VDI $(BIN_DIR)/$(IMG_PREFIX)-ext2.image $(BIN_DIR)/$(IMG_PREFIX)-ext2.vdi
-    endif
-  endef
-endif
-
-ifeq ($(CONFIG_X86_VMDK_IMAGES),y)
-  define Image/Build/vmdk
-    # left here because the image builder doesnt need these
-    ifeq ($(1),ext2)
-               rm $(BIN_DIR)/$(IMG_PREFIX)-ext2.vmdk || true
-               qemu-img convert -f raw $(BIN_DIR)/$(IMG_PREFIX)-ext2.image \
-                       -O vmdk $(BIN_DIR)/$(IMG_PREFIX)-ext2.vmdk
-    endif
-  endef
 endif
 
 ROOTDELAY=10
 
-ifeq ($(CONFIG_OLPC_BOOTSCRIPT_IMAGES),y)
-  define Image/cmdline/squashfs
-    block2mtd.block2mtd=$(ROOTPART),65536,rootfs root=/dev/mtdblock0 rootfstype=squashfs rootdelay=$(ROOTDELAY)
+ifneq ($(CONFIG_OLPC_BOOTSCRIPT_IMAGES),)
+
+  define Image/cmdline/ext4
+    root=$(ROOTPART) rootfstype=ext4 rootwait
   endef
 
   define Image/cmdline/jffs2-64k
@@ -126,8 +112,8 @@ ifeq ($(CONFIG_OLPC_BOOTSCRIPT_IMAGES),y)
     block2mtd.block2mtd=$(ROOTPART),131072,rootfs root=/dev/mtdblock0 rootfstype=jffs2 rootdelay=$(ROOTDELAY)
   endef
 
-  define Image/cmdline/ext2
-    root=$(ROOTPART) rootfstype=ext2 rootwait
+  define Image/cmdline/squashfs
+    block2mtd.block2mtd=$(ROOTPART),65536,rootfs root=/dev/mtdblock0 rootfstype=squashfs rootdelay=$(ROOTDELAY)
   endef
 
   define Image/Build/bootscript
@@ -136,68 +122,152 @@ ifeq ($(CONFIG_OLPC_BOOTSCRIPT_IMAGES),y)
        $(CP) $(KDIR)/bzImage $(KDIR)/root.bootscript/boot/vmlinuz
        sed -e 's#@CMDLINE@#$(strip $(call Image/cmdline/$(1))) $(BOOTOPTS)#g' \
                ./olpc.fth > $(KDIR)/root.bootscript/boot/olpc.fth
-       PADDING="$(CONFIG_OLPC_BOOTSCRIPT_IMAGES_PAD)" PATH="$(TARGET_PATH)" ./gen_image_olpc.sh $(BIN_DIR)/$(IMG_PREFIX)-$(1).image $(CONFIG_OLPC_BOOTSCRIPT_KERNELPART) $(KDIR)/root.bootscript $(CONFIG_TARGET_ROOTFS_FSPART) $(KDIR)/root.$(1)
+       PADDING="$(CONFIG_TARGET_IMAGES_PAD)" PATH="$(TARGET_PATH)" ./gen_image_olpc.sh \
+               $(BIN_DIR)/$(IMG_PREFIX)-combined-$(1).img \
+               $(CONFIG_TARGET_KERNEL_PARTSIZE) $(KDIR)/root.bootscript \
+               $(CONFIG_TARGET_ROOTFS_PARTSIZE) $(KDIR)/root.$(1)
   endef
-endif
 
-define Image/Prepare
-       $(CP) $(LINUX_DIR)/arch/x86/boot/bzImage $(KDIR)/bzImage
-ifeq ($(CONFIG_TARGET_x86_olpc),y)
-       $(call Image/Prepare/bootscript)
-else
-       $(call Image/Prepare/grub)
 endif
-endef
 
 define Image/Build/squashfs
-    $(call prepare_generic_squashfs,$(KDIR)/root.squashfs)
+       $(call prepare_generic_squashfs,$(KDIR)/root.squashfs)
 endef
 
-define Image/Build/iso 
-       $(INSTALL_DIR) $(KDIR)/root.grub/boot/grub
-       $(CP) \
-               $(STAGING_DIR_HOST)/usr/lib/grub/i386-openwrt/stage2_eltorito \
-               $(KDIR)/root.grub/boot/grub/stage2_eltorito 
+define Image/Build/iso
+       $(INSTALL_DIR) $(KDIR)/root.grub/boot/grub $(KDIR)/grub2
+       $(CP) $(KDIR)/bzImage $(KDIR)/root.grub/boot/vmlinuz
+       grub-mkimage \
+               -d $(STAGING_DIR_HOST)/lib/grub/i386-pc \
+               -o $(KDIR)/grub2/eltorito.img \
+               -O i386-pc \
+               -c ./grub-early.cfg \
+               $(GRUB2_MODULES_ISO)
+       cat \
+               $(STAGING_DIR_HOST)/lib/grub/i386-pc/cdboot.img \
+               $(KDIR)/grub2/eltorito.img \
+               > $(KDIR)/root.grub/boot/grub/eltorito.img
        sed \
                -e 's#@SERIAL_CONFIG@#$(strip $(GRUB_SERIAL_CONFIG))#g' \
                -e 's#@TERMINAL_CONFIG@#$(strip $(GRUB_TERMINAL_CONFIG))#g' \
-               -e 's#@CMDLINE@#$(strip $(call Image/cmdline/$(1)) $(BOOTOPTS) $(GRUB_CONSOLE_CMDLINE))#g' \
-               -e 's#(hd0,0)#(cd)#g' \
-               ./menu.lst > $(KDIR)/root.grub/boot/grub/menu.lst
-       $(CP) $(KDIR)/bzImage $(KDIR)/root.grub/boot/vmlinuz 
-       mkisofs -R -b boot/grub/stage2_eltorito -no-emul-boot -boot-load-size 4 -boot-info-table \
-               -o $(KDIR)/root.iso $(KDIR)/root.grub 
-endef 
+               -e 's#@CMDLINE@#root=/dev/sr0 rootfstype=iso9660 rootwait $(strip $(call Image/cmdline/$(1)) $(BOOTOPTS) $(GRUB_CONSOLE_CMDLINE))#g' \
+               -e 's#@TIMEOUT@#$(GRUB_TIMEOUT)#g' \
+               ./grub-iso.cfg > $(KDIR)/root.grub/boot/grub/grub.cfg
+       $(CP) $(KDIR)/bzImage $(KDIR)/root.grub/boot/vmlinuz
+       mkisofs -R -b boot/grub/eltorito.img -no-emul-boot -boot-info-table \
+               -o $(KDIR)/root.iso $(KDIR)/root.grub $(TARGET_DIR)
+endef
+
+ifneq ($(CONFIG_VDI_IMAGES),)
+  define Image/Build/vdi
+    # left here because the image builder doesnt need these
+    ifeq ($(1),ext4)
+               rm $(BIN_DIR)/$(IMG_PREFIX)-combined-$(1).vdi || true
+               qemu-img convert -f raw -O vdi \
+                       $(BIN_DIR)/$(IMG_PREFIX)-combined-$(1).img \
+                       $(BIN_DIR)/$(IMG_PREFIX)-combined-$(1).vdi
+               # XXX: VBoxManage insists on setting perms to 0600
+               chmod 0644 $(BIN_DIR)/$(IMG_PREFIX)-combined-$(1).vdi
+    endif
+  endef
+endif
+
+ifneq ($(CONFIG_VMDK_IMAGES),)
+  define Image/Build/vmdk
+    # left here because the image builder doesnt need these
+    ifeq ($(1),ext4)
+               rm $(BIN_DIR)/$(IMG_PREFIX)-combined-$(1).vmdk || true
+               qemu-img convert -f raw -O vmdk \
+                       $(BIN_DIR)/$(IMG_PREFIX)-combined-$(1).img \
+                       $(BIN_DIR)/$(IMG_PREFIX)-combined-$(1).vmdk
+    endif
+  endef
+endif
+
+define Image/Build/gzip
+       gzip -f9 $(BIN_DIR)/$(IMG_PREFIX)-combined-$(1).img
+       gzip -f9 $(BIN_DIR)/$(IMG_PREFIX)-rootfs-$(1).img
+endef
+
+ifneq ($(CONFIG_TARGET_IMAGES_GZIP),)
+  define Image/Build/gzip/ext4
+       $(call Image/Build/gzip,ext4)
+  endef
+  ifneq ($(CONFIG_TARGET_IMAGES_PAD),)
+    define Image/Build/gzip/squashfs
+       $(call Image/Build/gzip,squashfs)
+    endef
+    define Image/Build/gzip/jffs2-64k
+       $(call Image/Build/gzip,jffs2-64k)
+    endef
+    define Image/Build/gzip/jffs2-128k
+       $(call Image/Build/gzip,jffs2-128k)
+    endef
+  endif
+endif
 
 define Image/BuildKernel
        $(CP) $(KDIR)/bzImage $(BIN_DIR)/$(IMG_PREFIX)-vmlinuz
+  ifneq ($(CONFIG_X86_ETHERBOOT_IMAGES),)
+       rm -f $(BIN_DIR)/$(IMG_PREFIX)-etherboot
+       $(STAGING_DIR_HOST)/bin/mkelfImage \
+               --append=$(CONFIG_X86_ETHERBOOT_BOOTOPTS) \
+               $(KDIR)/bzImage \
+               $(BIN_DIR)/$(IMG_PREFIX)-etherboot
+  endif
+endef
+
+define Image/Build/Profile/ar525w
+       cp $(KDIR)/bzImage $(KDIR)/bzImage.tmp
+       $(SCRIPT_DIR)/pad_image $(1) $(KDIR)/bzImage.tmp $(KDIR)/root.$(1) 32
+       $(STAGING_DIR_HOST)/bin/airlink -b 1 $(KDIR)/bzImage.tmp $(KDIR)/root.$(1) \
+               $(BIN_DIR)/$(IMG_PREFIX)-$(1)-ar525w.img
+       $(STAGING_DIR_HOST)/bin/airlink -e -b 1 $(KDIR)/bzImage.tmp $(KDIR)/root.$(1) \
+               $(BIN_DIR)/$(IMG_PREFIX)-$(1)-ar525w-web.img
+endef
+
+define Image/Build/Profile/sitecom
+       cp $(KDIR)/bzImage $(KDIR)/bzImage.tmp
+       #32k config data + 20 bytes header + 2 bytes checksum after kernel image
+       $(SCRIPT_DIR)/pad_image $(1) $(KDIR)/bzImage.tmp $(KDIR)/root.$(1) 32790
+       $(TOPDIR)/target/linux/rdc/image/mkimg_sitecom.pl $(KDIR)/bzImage.tmp > $(KDIR)/tmp.img
+       cat $(KDIR)/root.$(1) >> $(KDIR)/tmp.img
+       cp $(KDIR)/tmp.img $(BIN_DIR)/$(IMG_PREFIX)-$(1)-sitecom.img
+       rm $(KDIR)/tmp.img $(KDIR)/bzImage.tmp
+endef
+
+define Image/Build/Profile/bifferboard
+       $(TOPDIR)/target/linux/rdc/image/mkimg_bifferboard.py $(KDIR)/bzImage $(KDIR)/root.$(1) \
+               $(BIN_DIR)/$(IMG_PREFIX)-$(1)-bifferboard.img
+endef
+
+define Image/Prepare
+       $(CP) $(LINUX_DIR)/arch/x86/boot/bzImage $(KDIR)/bzImage
+       $(call Image/Prepare/bootscript)
+       $(call Image/Prepare/grub2)
+endef
+
+define Image/Build/Initramfs
+       $(CP) $(KDIR)/bzImage-initramfs $(BIN_DIR)/$(IMG_PREFIX)-ramfs.bzImage
 endef
 
 define Image/Build
        $(call Image/Build/$(1))
        $(call Image/Build/bootscript,$(1))
   ifneq ($(1),iso)
-       $(call Image/Build/grub,$(1))
+       $(call Image/Build/grub2,$(1))
        $(call Image/Build/vdi,$(1))
        $(call Image/Build/vmdk,$(1))
+       $(CP) $(KDIR)/root.$(1) $(BIN_DIR)/$(IMG_PREFIX)-rootfs-$(1).img
+  else
+       $(CP) $(KDIR)/root.iso $(BIN_DIR)/$(IMG_PREFIX).iso
   endif
-       $(CP) $(KDIR)/root.$(1) $(BIN_DIR)/$(IMG_PREFIX)-$(1).fs
        $(CP) $(KDIR)/bzImage $(BIN_DIR)/$(IMG_PREFIX)-vmlinuz
-  ifeq ($(1),ext2)
-       gzip -f9 $(BIN_DIR)/$(IMG_PREFIX)-$(1).image
-  endif
+       $(call Image/Build/gzip/$(1))
+       $(call Image/Build/Profile/$(PROFILE),$(1))
+ifeq ($(CONFIG_TARGET_ROOTFS_INITRAMFS),y)
+       $(call Image/Build/Initramfs)
+endif
 endef
 
 $(eval $(call BuildImage))
-
-ifeq ($(CONFIG_X86_VDI_IMAGES),y)
-  $(eval $(call RequireCommand,VBoxManage, \
-       You need VBoxManage to generate VirtualBox images. \
-  ))
-endif
-
-ifeq ($(CONFIG_X86_VMDK_IMAGES),y)
-   $(eval $(call RequireCommand,qemu-img, \
-       You need qemu-img to generate VMware images. \
-   ))
-endif