x86: add support to set GRUB menu entry title
[openwrt/openwrt.git] / target / linux / x86 / image / Makefile
index ffda5c1578cd4f7d1e2de9ef48af4b729d492c4b..b537c40f24e6c3c2a2d76fb36095205e8eaaa7cd 100644 (file)
@@ -15,8 +15,9 @@ GRUB_TERMINALS =
 GRUB_SERIAL_CONFIG =
 GRUB_TERMINAL_CONFIG =
 GRUB_CONSOLE_CMDLINE =
+GRUB_ROOT = hd0,msdos1
 
-USE_ATKBD = generic kvm_guest
+USE_ATKBD = generic 64
 
 ifneq ($(strip $(foreach subtarget,$(USE_ATKBD),$(CONFIG_TARGET_x86_$(subtarget)))),)
   GRUB2_MODULES += at_keyboard
@@ -31,8 +32,8 @@ endif
 GRUB_SERIAL:=$(call qstrip,$(CONFIG_GRUB_SERIAL))
 
 ifneq ($(GRUB_SERIAL),)
-  GRUB_CONSOLE_CMDLINE += console=$(GRUB_SERIAL),$(CONFIG_GRUB_BAUDRATE)n8
-  GRUB_SERIAL_CONFIG := serial --unit=0 --speed=$(CONFIG_GRUB_BAUDRATE) --word=8 --parity=no --stop=1 --rtscts=off
+  GRUB_CONSOLE_CMDLINE += console=$(GRUB_SERIAL),$(CONFIG_GRUB_BAUDRATE)n8$(if $(CONFIG_GRUB_FLOWCONTROL),r,)
+  GRUB_SERIAL_CONFIG := serial --unit=0 --speed=$(CONFIG_GRUB_BAUDRATE) --word=8 --parity=no --stop=1 --rtscts=$(if $(CONFIG_GRUB_FLOWCONTROL),on,off)
   GRUB_TERMINALS += serial
 endif
 
@@ -40,11 +41,16 @@ ifneq ($(GRUB_TERMINALS),)
   GRUB_TERMINAL_CONFIG := terminal_input $(GRUB_TERMINALS); terminal_output $(GRUB_TERMINALS)
 endif
 
-SIGNATURE:=$(shell dd if=/dev/urandom bs=4 count=1 2>/dev/null | hexdump -v -e '"%08x"')
+SIGNATURE:=$(shell perl -e 'printf("%08x", rand(0xFFFFFFFF))')
 ROOTPART:=$(call qstrip,$(CONFIG_TARGET_ROOTFS_PARTNAME))
 ROOTPART:=$(if $(ROOTPART),$(ROOTPART),PARTUUID=$(SIGNATURE)-02)
 
 GRUB_TIMEOUT:=$(call qstrip,$(CONFIG_GRUB_TIMEOUT))
+GRUB_TITLE:=$(call qstrip,$(CONFIG_GRUB_TITLE))
+
+ifneq ($(CONFIG_TARGET_x86_xen_domu),)
+  GRUB_ROOT = xen/xvda,msdos1
+endif
 
 ifneq ($(CONFIG_GRUB_IMAGES),)
 
@@ -54,16 +60,8 @@ ifneq ($(CONFIG_GRUB_IMAGES),)
     root=$(ROOTPART) rootfstype=ext4 rootwait
   endef
 
-  define Image/cmdline/jffs2-64k
-    block2mtd.block2mtd=$(ROOTPART),65536,rootfs,5 root=/dev/mtdblock0 rootfstype=jffs2 rootwait
-  endef
-
-  define Image/cmdline/jffs2-128k
-    block2mtd.block2mtd=$(ROOTPART),131072,rootfs,5 root=/dev/mtdblock0 rootfstype=jffs2 rootwait
-  endef
-
   define Image/cmdline/squashfs
-    block2mtd.block2mtd=$(ROOTPART),65536,rootfs,5 root=/dev/mtdblock0 rootfstype=squashfs rootwait
+    root=$(ROOTPART) rootfstype=squashfs rootwait
   endef
 
   define Image/Build/grub2
@@ -71,6 +69,7 @@ ifneq ($(CONFIG_GRUB_IMAGES),)
        $(INSTALL_DIR) $(KDIR)/root.grub/boot/grub $(KDIR)/grub2
        $(CP) $(KDIR)/bzImage $(KDIR)/root.grub/boot/vmlinuz
        grub-mkimage \
+               -p /boot/grub \
                -d $(STAGING_DIR_HOST)/lib/grub/i386-pc \
                -o $(KDIR)/grub2/core.img \
                -O i386-pc \
@@ -83,8 +82,10 @@ ifneq ($(CONFIG_GRUB_IMAGES),)
                -e 's#@TERMINAL_CONFIG@#$(strip $(GRUB_TERMINAL_CONFIG))#g' \
                -e 's#@CMDLINE@#$(strip $(call Image/cmdline/$(1)) $(BOOTOPTS) $(GRUB_CONSOLE_CMDLINE))#g' \
                -e 's#@TIMEOUT@#$(GRUB_TIMEOUT)#g' \
+               -e 's#@ROOT@#$(GRUB_ROOT)#g' \
+               -e 's#@TITLE@#$(GRUB_TITLE)#g' \
                ./grub.cfg > $(KDIR)/root.grub/boot/grub/grub.cfg
-       PADDING="$(CONFIG_TARGET_IMAGES_PAD)" SIGNATURE="$(SIGNATURE)" PATH="$(TARGET_PATH)" ./gen_image_generic.sh \
+       PADDING="$(CONFIG_TARGET_IMAGES_PAD)" SIGNATURE="$(SIGNATURE)" PATH="$(TARGET_PATH)" $(SCRIPT_DIR)/gen_image_generic.sh \
                $(BIN_DIR)/$(IMG_PREFIX)-combined-$(1).img \
                $(CONFIG_TARGET_KERNEL_PARTSIZE) $(KDIR)/root.grub \
                $(CONFIG_TARGET_ROOTFS_PARTSIZE) $(KDIR)/root.$(1) \
@@ -94,20 +95,18 @@ ifneq ($(CONFIG_GRUB_IMAGES),)
                -d "$(KDIR)/grub2" \
                -r "hd0,msdos1" \
                "$(BIN_DIR)/$(IMG_PREFIX)-combined-$(1).img"
-       $(call Image/Build/grub/$(1))
   endef
 endif
 
-ROOTDELAY=10
-
 define Image/Build/squashfs
-       $(call prepare_generic_squashfs,$(KDIR)/root.squashfs)
+       dd if=/dev/zero bs=128k count=1 >> $(KDIR)/root.squashfs
 endef
 
 define Image/Build/iso
        $(INSTALL_DIR) $(KDIR)/root.grub/boot/grub $(KDIR)/grub2
        $(CP) $(KDIR)/bzImage $(KDIR)/root.grub/boot/vmlinuz
        grub-mkimage \
+               -p /boot/grub \
                -d $(STAGING_DIR_HOST)/lib/grub/i386-pc \
                -o $(KDIR)/grub2/eltorito.img \
                -O i386-pc \
@@ -122,8 +121,8 @@ define Image/Build/iso
                -e 's#@TERMINAL_CONFIG@#$(strip $(GRUB_TERMINAL_CONFIG))#g' \
                -e 's#@CMDLINE@#root=/dev/sr0 rootfstype=iso9660 rootwait $(strip $(call Image/cmdline/$(1)) $(BOOTOPTS) $(GRUB_CONSOLE_CMDLINE))#g' \
                -e 's#@TIMEOUT@#$(GRUB_TIMEOUT)#g' \
+               -e 's#@TITLE@#$(GRUB_TITLE)#g' \
                ./grub-iso.cfg > $(KDIR)/root.grub/boot/grub/grub.cfg
-       $(CP) $(KDIR)/bzImage $(KDIR)/root.grub/boot/vmlinuz
        mkisofs -R -b boot/grub/eltorito.img -no-emul-boot -boot-info-table \
                -o $(KDIR)/root.iso $(KDIR)/root.grub $(TARGET_DIR)
 endef
@@ -149,64 +148,24 @@ ifneq ($(CONFIG_VMDK_IMAGES),)
 endif
 
 define Image/Build/gzip
-       gzip -f9 $(BIN_DIR)/$(IMG_PREFIX)-combined-$(1).img
-       gzip -f9 $(BIN_DIR)/$(IMG_PREFIX)-rootfs-$(1).img
+       gzip -f9n $(BIN_DIR)/$(IMG_PREFIX)-combined-$(1).img
+       gzip -f9n $(BIN_DIR)/$(IMG_PREFIX)-rootfs-$(1).img
 endef
 
 ifneq ($(CONFIG_TARGET_IMAGES_GZIP),)
   define Image/Build/gzip/ext4
        $(call Image/Build/gzip,ext4)
   endef
-  ifneq ($(CONFIG_TARGET_IMAGES_PAD),)
-    define Image/Build/gzip/squashfs
+  define Image/Build/gzip/squashfs
        $(call Image/Build/gzip,squashfs)
-    endef
-    define Image/Build/gzip/jffs2-64k
-       $(call Image/Build/gzip,jffs2-64k)
-    endef
-    define Image/Build/gzip/jffs2-128k
-       $(call Image/Build/gzip,jffs2-128k)
-    endef
-  endif
+  endef
 endif
 
 define Image/BuildKernel
        $(CP) $(KDIR)/bzImage $(BIN_DIR)/$(IMG_PREFIX)-vmlinuz
-  ifneq ($(CONFIG_X86_ETHERBOOT_IMAGES),)
-       rm -f $(BIN_DIR)/$(IMG_PREFIX)-etherboot
-       $(STAGING_DIR_HOST)/bin/mkelfImage \
-               --append=$(CONFIG_X86_ETHERBOOT_BOOTOPTS) \
-               $(KDIR)/bzImage \
-               $(BIN_DIR)/$(IMG_PREFIX)-etherboot
-  endif
-endef
-
-define Image/Build/Profile/ar525w
-       cp $(KDIR)/bzImage $(KDIR)/bzImage.tmp
-       $(SCRIPT_DIR)/pad_image $(1) $(KDIR)/bzImage.tmp $(KDIR)/root.$(1) 32
-       $(STAGING_DIR_HOST)/bin/airlink -b 1 $(KDIR)/bzImage.tmp $(KDIR)/root.$(1) \
-               $(BIN_DIR)/$(IMG_PREFIX)-$(1)-ar525w.img
-       $(STAGING_DIR_HOST)/bin/airlink -e -b 1 $(KDIR)/bzImage.tmp $(KDIR)/root.$(1) \
-               $(BIN_DIR)/$(IMG_PREFIX)-$(1)-ar525w-web.img
-endef
-
-define Image/Build/Profile/sitecom
-       cp $(KDIR)/bzImage $(KDIR)/bzImage.tmp
-       #32k config data + 20 bytes header + 2 bytes checksum after kernel image
-       $(SCRIPT_DIR)/pad_image $(1) $(KDIR)/bzImage.tmp $(KDIR)/root.$(1) 32790
-       $(TOPDIR)/target/linux/rdc/image/mkimg_sitecom.pl $(KDIR)/bzImage.tmp > $(KDIR)/tmp.img
-       cat $(KDIR)/root.$(1) >> $(KDIR)/tmp.img
-       cp $(KDIR)/tmp.img $(BIN_DIR)/$(IMG_PREFIX)-$(1)-sitecom.img
-       rm $(KDIR)/tmp.img $(KDIR)/bzImage.tmp
-endef
-
-define Image/Build/Profile/bifferboard
-       $(TOPDIR)/target/linux/rdc/image/mkimg_bifferboard.py $(KDIR)/bzImage $(KDIR)/root.$(1) \
-               $(BIN_DIR)/$(IMG_PREFIX)-$(1)-bifferboard.img
 endef
 
 define Image/Prepare
-       $(CP) $(LINUX_DIR)/arch/x86/boot/bzImage $(KDIR)/bzImage
        $(call Image/Prepare/grub2)
 endef
 
@@ -226,7 +185,6 @@ define Image/Build
   endif
        $(CP) $(KDIR)/bzImage $(BIN_DIR)/$(IMG_PREFIX)-vmlinuz
        $(call Image/Build/gzip/$(1))
-       $(call Image/Build/Profile/$(PROFILE),$(1))
 ifeq ($(CONFIG_TARGET_ROOTFS_INITRAMFS),y)
        $(call Image/Build/Initramfs)
 endif