use immediate set in target Makefiles
[openwrt/openwrt.git] / target / linux / xburst / Makefile
index 4f89fd54027a1c6987597ce58f7c4cf35f0817e0..2a64b7c46fa04b8693105d809469a050354bd751 100644 (file)
@@ -9,17 +9,17 @@ include $(TOPDIR)/rules.mk
 ARCH:=mipsel
 BOARD:=xburst
 BOARDNAME:=Ingenic XBurst
-FEATURES:=targz ubifs audio
-SUBTARGETS:=qi_lb60 n516 n526 id800wt
+FEATURES:=targz nand ubifs audio
+SUBTARGETS:=qi_lb60
 
-LINUX_VERSION:=3.10.17
+KERNEL_PATCHVER:=3.18
 
-DEVICE_TYPE=other
-
-include $(INCLUDE_DIR)/target.mk
+DEVICE_TYPE:=other
 
 define Target/Description
        Build firmware images for XBurst JZ47x0 based boards.
 endef
 
+include $(INCLUDE_DIR)/target.mk
+
 $(eval $(call BuildTarget))