use immediate set in target Makefiles
[openwrt/openwrt.git] / target / linux / xburst / Makefile
index 67de2cc6d95117b79f6aedf13c010a8219429b01..2a64b7c46fa04b8693105d809469a050354bd751 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2009-2010 OpenWrt.org
+# Copyright (C) 2009-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,21 +8,18 @@ include $(TOPDIR)/rules.mk
 
 ARCH:=mipsel
 BOARD:=xburst
-BOARDNAME:=XBurst JZ47x0
-FEATURES:=jffs2 tgz ubifs
+BOARDNAME:=Ingenic XBurst
+FEATURES:=targz nand ubifs audio
+SUBTARGETS:=qi_lb60
 
-LINUX_VERSION:=2.6.32.6
+KERNEL_PATCHVER:=3.18
 
-DEVICE_TYPE=other
-
-include $(INCLUDE_DIR)/target.mk
-
-KERNELNAME:=uImage
-
-DEFAULT_PACKAGES += gpioctl
+DEVICE_TYPE:=other
 
 define Target/Description
        Build firmware images for XBurst JZ47x0 based boards.
 endef
 
+include $(INCLUDE_DIR)/target.mk
+
 $(eval $(call BuildTarget))