use immediate set in target Makefiles
[openwrt/openwrt.git] / target / linux / xburst / Makefile
index fe4143da057b7f8d68d9325a9871d20fa29b10ae..2a64b7c46fa04b8693105d809469a050354bd751 100644 (file)
@@ -9,17 +9,17 @@ include $(TOPDIR)/rules.mk
 ARCH:=mipsel
 BOARD:=xburst
 BOARDNAME:=Ingenic XBurst
-FEATURES:=targz nand ubifs audio broken
+FEATURES:=targz nand ubifs audio
 SUBTARGETS:=qi_lb60
 
-KERNEL_PATCHVER:=3.10
+KERNEL_PATCHVER:=3.18
 
-DEVICE_TYPE=other
-
-include $(INCLUDE_DIR)/target.mk
+DEVICE_TYPE:=other
 
 define Target/Description
        Build firmware images for XBurst JZ47x0 based boards.
 endef
 
+include $(INCLUDE_DIR)/target.mk
+
 $(eval $(call BuildTarget))