xburst: remove hack to determine entry point
[openwrt/openwrt.git] / target / linux / xburst / image / Makefile
index 199ba2b7d4eb720c86decb92f2807673789c6f5a..ff25fbebcc4726f8d553c1be5bfeabd43b7ba214 100644 (file)
@@ -1,24 +1,38 @@
 #
-# Copyright (C) 2009 OpenWrt.org
+# Copyright (C) 2009-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-include $(TOPDIR)/rules.mk
-include $(INCLUDE_DIR)/image.mk
 
 JFFS2_BLOCKSIZE=256k 512k
 
+include $(TOPDIR)/rules.mk
+include $(INCLUDE_DIR)/image.mk
+
 ifneq ($(CONFIG_TARGET_xburst_qi_lb60),)
+UBI_OPTS = -m 4096 -p 512KiB
 UBIFS_OPTS = -m 4096 -e 516096 -c 4095
-UBINIZE_OPTS = -m 4096 -p 512KiB
 else
+UBI_OPTS = -m 2048 -p 128KiB -s 512
 UBIFS_OPTS = -m 2048 -e 126KiB -c 4096
-UBINIZE_OPTS = -m 2048 -p 128KiB -s 512
 endif
 
+UIMAGE:=$(BIN_DIR)/$(IMG_PREFIX)-uImage.bin
+
+define MkImageGzip
+       gzip -9n -c $(1) > $(1).gz
+       mkimage -A mips -O linux -T kernel -a 0x80010000 -C gzip \
+               -e 0x80010000 -n 'MIPS OpenWrt Linux-$(LINUX_VERSION)' \
+               -d $(1).gz $(2)
+endef
+
+define Image/Prepare
+       $(call MkImageGzip,$(KDIR)/vmlinux,$(KDIR)/uimage)
+endef
+
 define Image/BuildKernel
-       cp $(KDIR)/linux-$(LINUX_VERSION)/arch/mips/boot/uImage $(BIN_DIR)/openwrt-$(BOARD)-uImage.bin
+       cp $(KDIR)/uimage $(UIMAGE)
 endef
 
 define Image/Build/squashfs
@@ -26,7 +40,7 @@ define Image/Build/squashfs
 endef
 
 define Image/Build
-       dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/openwrt-$(BOARD)-$(SUBTARGET)-root.$(1) bs=128k conv=sync
+       dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/$(IMG_PREFIX)-root.$(1) bs=128k conv=sync
 endef
 
 $(eval $(call BuildImage))