sdk: do not strip static libraries
[openwrt/openwrt.git] / target / sdk / Makefile
index e9599c3c69ee0142567b2021a728e29b81d52b08..496f0253936f5b7ff398a23cfd07a6521ce64e6d 100644 (file)
@@ -92,7 +92,7 @@ $(BIN_DIR)/$(SDK_NAME).tar.xz: clean
                find \
                        $(SDK_BUILD_DIR)/$(STAGING_SUBDIR_HOST)/lib \
                        $(SDK_BUILD_DIR)/$(STAGING_SUBDIR_HOST)/usr/lib \
-                       -type f -name \*.so\* -or -name \*.a; \
+                       -type f -name \*.so\*; \
        ) | xargs strip 2>/dev/null >/dev/null
 
        mkdir -p $(SDK_BUILD_DIR)/target/linux