modules: Add kernel module for MV88E6xxx DSA switch
[openwrt/openwrt.git] / target / sdk / files / Makefile
index f1e0eadbea86104e67d6c4b2af8e7c64006a59a0..89c6a109eee02010686a10d9cd5ac77ff5edbd48 100644 (file)
@@ -1,6 +1,6 @@
 # Makefile for OpenWrt
 #
-# Copyright (C) 2007 OpenWrt.org
+# Copyright (C) 2007-2015 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -14,11 +14,19 @@ export TOPDIR LC_ALL LANG SDK
 
 world:
 
-include $(TOPDIR)/include/host.mk
+DISTRO_PKG_CONFIG:=$(shell $(TOPDIR)/scripts/command_all.sh pkg-config | grep '/usr' -m 1)
+
+export ORIG_PATH:=$(if $(ORIG_PATH),$(ORIG_PATH),$(PATH))
+export PATH:=$(TOPDIR)/staging_dir/host/bin:$(PATH)
 
 ifneq ($(OPENWRT_BUILD),1)
   override OPENWRT_BUILD=1
   export OPENWRT_BUILD
+
+  empty:=
+  space:= $(empty) $(empty)
+  _SINGLE=export MAKEFLAGS=$(space);
+
   include $(TOPDIR)/include/debug.mk
   include $(TOPDIR)/include/depends.mk
   include $(TOPDIR)/include/toplevel.mk
@@ -31,22 +39,22 @@ else
 $(package/stamp-compile): $(BUILD_DIR)/.prepared
 $(BUILD_DIR)/.prepared: Makefile
        @mkdir -p $$(dirname $@)
-       @mkdir -p bin/packages
        @touch $@
 
 clean: FORCE
-       rm -rf $(BUILD_DIR) $(BIN_DIR)
+       git clean -f -d $(STAGING_DIR); true
+       git clean -f -d $(BUILD_DIR); true
+       git clean -f -d $(BIN_DIR); true
 
 dirclean: clean
-       rm -rf $(TMP_DIR)
+       git reset --hard HEAD
+       git clean -f -d
+       rm -rf feeds/
 
 # check prerequisites before starting to build
 prereq: $(package/stamp-prereq) ;
 
 world: prepare $(package/stamp-compile) FORCE
-       @for configfile in `find package -maxdepth 2 -name Config.in` ; do \
-               $(MAKE) compile -C `dirname $$configfile`; \
-       done
        @$(MAKE) package/index
 
 .PHONY: clean dirclean prereq prepare world