ar71xx: Remove ath10k packages from archer-c7-v1 (fixes FS#1743)
[openwrt/openwrt.git] / toolchain / Makefile
index 456b731fb88d540d2ec57287b180394deb449f26..0336b2f72cee18fefa66cce218c553b9b99a6e30 100644 (file)
@@ -1,5 +1,5 @@
 # 
-# Copyright (C) 2007-2008 OpenWrt.org
+# Copyright (C) 2007-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -7,65 +7,93 @@
 # Main makefile for the toolchain
 #
 # Steps:
-# 1) toolchain/binutils/install
+# 1) toolchain/binutils/compile
 #    build & install binutils
-# 2) toolchain/gcc/prepare
+# 2) toolchain/gcc/minimal/compile
 #    build & install a minimal gcc, needed for steps 3 & 4
-# 3) toolchain/kernel-headers/install
+# 3) toolchain/kernel-headers/compile
 #    install kernel headers, needed for step 4
-# 4) toolchain/libc/prepare
+# 4) toolchain/libc/headers/compile
 #    build & install libc headers & support files, needed for step 5
-# 5) toolchain/gcc/compile
+# 5) toolchain/gcc/initial/compile
 #    build & install an initial gcc, needed for step 6
 # 6) toolchain/libc/compile
 #    build & install the final libc
-# 7) toolchain/gcc/install
+# 7) toolchain/gcc/final/compile
 #    build & install the final gcc
-# 8) toolchain/libc/install
+# 8) toolchain/libc/utils/compile
 #    build & install libc utilities
 #
+# For musl, steps 2 and 4 are skipped, and step 3 is done after 5
 
 curdir:=toolchain
 
 # subdirectories to descend into
-$(curdir)/builddirs := kernel-headers $(if $(CONFIG_GDB),gdb) $(if $(CONFIG_INSIGHT),insight) $(if $(CONFIG_NATIVE_TOOLCHAIN),,binutils gcc $(LIBC) $(if $(CONFIG_GLIBC_PORTS),glibc-ports))
-$(curdir)/builddirs-compile:=$($(curdir)/builddirs-prepare)
-$(curdir)/builddirs-install:=$($(curdir)/builddirs-compile)
+$(curdir)/builddirs := $(if $(CONFIG_GDB),gdb) $(if $(CONFIG_EXTERNAL_TOOLCHAIN),wrapper,kernel-headers binutils gcc/initial gcc/final $(LIBC) fortify-headers) $(if $(CONFIG_NASM),nasm)
+ifdef CONFIG_USE_UCLIBC
+  $(curdir)/builddirs += $(LIBC)/utils
+endif
 
 # builddir dependencies
-$(curdir)/$(LIBC)/prepare:=$(curdir)/kernel-headers/install
-ifeq ($(CONFIG_NATIVE_TOOLCHAIN),)
-  $(curdir)/gcc/prepare:=$(curdir)/binutils/install
-  $(curdir)/kernel-headers/install:=$(curdir)/gcc/prepare
-  $(curdir)/gcc/compile:=$(curdir)/$(LIBC)/prepare
-  $(curdir)/$(LIBC)/compile:=$(curdir)/gcc/compile
-  $(curdir)/gcc/install:=$(curdir)/$(LIBC)/compile
-  $(curdir)/$(LIBC)/install:=$(curdir)/gcc/install
-  ifneq ($(CONFIG_GLIBC_PORTS),)
-    $(curdir)/glibc/prepare:=$(curdir)/glibc-ports/prepare
+ifeq ($(CONFIG_EXTERNAL_TOOLCHAIN),)
+  ifdef CONFIG_USE_MUSL
+    $(curdir)/kernel-headers/compile:=$(curdir)/gcc/initial/compile
+    $(curdir)/$(LIBC)/compile:=$(curdir)/kernel-headers/compile
+  else
+    $(curdir)/builddirs += $(LIBC)/headers gcc/minimal
+    $(curdir)/gcc/minimal/compile:=$(curdir)/binutils/compile
+    $(curdir)/kernel-headers/compile:=$(curdir)/gcc/minimal/compile
+    $(curdir)/$(LIBC)/headers/compile:=$(curdir)/kernel-headers/compile
+    $(curdir)/gcc/initial/compile:=$(curdir)/$(LIBC)/headers/compile
   endif
+
+  $(curdir)/gcc/initial/compile+=$(curdir)/binutils/compile
+  $(curdir)/$(LIBC)/compile:=$(curdir)/gcc/initial/compile
+  $(curdir)/gcc/final/compile:=$(curdir)/$(LIBC)/compile
+  $(curdir)/$(LIBC)/utils/compile:=$(curdir)/gcc/final/compile
 endif
 
+ifndef DUMP_TARGET_DB
 ifneq ($(ARCH),)
   $(TOOLCHAIN_DIR)/info.mk: .config
        @for dir in $(TOOLCHAIN_DIR); do ( \
-               set -x; \
+               $(if $(QUIET),,set -x;) \
                mkdir -p "$$dir"; \
                cd "$$dir"; \
+               ln -nsf lib lib64; \
+               ln -nsf lib lib32; \
                mkdir -p stamp lib usr/include usr/lib ; \
        ); done
        @grep GCC_VERSION $@ >/dev/null 2>&1 || $(INSTALL_DATA) $(TOPDIR)/toolchain/info.mk $@
        @touch $@
 endif
+endif
+
+ifdef CONFIG_BUILDBOT
+ifneq ($(wildcard $(TOPDIR)/.git),)
+  $(TOOLCHAIN_DIR)/stamp/.ver_check: $(TMP_DIR)/.build
+       cd "$(TOPDIR)"; git log --format=%h -1 toolchain > $(TMP_DIR)/.ver_check
+       cmp -s $(TMP_DIR)/.ver_check $@ || { \
+               rm -rf $(BUILD_DIR) $(STAGING_DIR) $(TOOLCHAIN_DIR) $(BUILD_DIR_TOOLCHAIN); \
+               mkdir -p $(TOOLCHAIN_DIR)/stamp; \
+               mv $(TMP_DIR)/.ver_check $@; \
+       }
+
+$(TOOLCHAIN_DIR)/info.mk $(STAGING_DIR)/.prepared: $(TOOLCHAIN_DIR)/stamp/.ver_check
+endif
+endif
 
 # prerequisites for the individual targets
 $(curdir)/ := .config prereq
-$(curdir)//prepare = $(STAGING_DIR)/.prepared $(TOOLCHAIN_DIR)/info.mk
-$(curdir)//compile = $(1)/prepare
-$(curdir)//install = $(1)/compile
+$(curdir)//compile = $(STAGING_DIR)/.prepared $(TOOLCHAIN_DIR)/info.mk $(tools/stamp-compile)
 
+ifndef DUMP_TARGET_DB
 $(TOOLCHAIN_DIR)/stamp/.gcc-initial_installed:
+endif
+
+$(curdir)/install: $(curdir)/compile
 
-$(eval $(call stampfile,$(curdir),toolchain,install,$(TOOLCHAIN_DIR)/stamp/.gcc-initial_installed,,$(TOOLCHAIN_DIR)))
+$(eval $(call stampfile,$(curdir),toolchain,compile,$(TOOLCHAIN_DIR)/stamp/.gcc-initial_installed,,$(TOOLCHAIN_DIR)))
+$(eval $(call stampfile,$(curdir),toolchain,check,$(TMP_DIR)/.build))
 $(eval $(call subdir,$(curdir)))